This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 125925

Summary: 'Toggle comment' for JavaScript and HTML with problems
Product: ruby Reporter: swperman <swperman>
Component: RHTMLAssignee: Erno Mononen <emononen>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:

Description swperman 2008-01-24 15:09:45 UTC
I have a .rhtml document with some JavaScript in it. When I select some JS code inside the <script> tags and issue the
toggle comment command (Ctrl+Shift+C), it wraps the code with "<%# %>" tags, instead of "//" as usual. The same for
HTML, I think it should use <!-- -->... It is specially bad to put "<%# %>" tags when there is already some embedded
Ruby code in the line... It gets all messed up!
Comment 1 Erno Mononen 2008-03-31 10:13:00 UTC
Still reproducible.
Comment 2 Erno Mononen 2009-10-27 16:53:36 UTC
This is a duplicate of #167300, closing this is the other issue has a higher priority. Please add your votes to that 
issue, otherwise they get lost - sorry about that, but unfortunately IZ doesn't transfer them automatically.

*** This issue has been marked as a duplicate of 167300 ***