This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 126812

Summary: AssertionError at com.sun.tools.javac.comp.Attr.visitNewClass
Product: java Reporter: unr303 <unr303>
Component: CompilerAssignee: Dusan Balek <dbalek>
Status: RESOLVED DUPLICATE    
Severity: blocker CC: unr303
Priority: P3    
Version: 6.x   
Hardware: PC   
OS: Windows XP   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=25045
Issue Type: DEFECT Exception Reporter: 25045
Bug Depends on:    
Bug Blocks: 152191    
Attachments: ide log
dump file
ide log
ide log
full file source
ide log
dump
ide log

Description unr303 2008-02-06 10:49:55 UTC
Build: NetBeans IDE Dev  Build 200802051752 
VM: Java HotSpot TM  Client VM, 10.0-b19
OS: Windows XP, 5.1, x86
User comments: editing code
STACKTRACE:  first 10 lines 
java.lang.AssertionError
        at com.sun.tools.javac.comp.Attr.visitNewClass Attr.java:1552 
        at com.sun.tools.javac.tree.JCTree$JCNewClass.accept JCTree.java:1351 
        at com.sun.tools.javac.comp.Attr.attribTree Attr.java:386 
        at com.sun.tools.javac.comp.Attr.attribArgs Attr.java:447 
        at com.sun.tools.javac.comp.Attr.visitNewClass Attr.java:1445 
        at com.sun.tools.javac.tree.JCTree$JCNewClass.accept JCTree.java:1351 
        at com.sun.tools.javac.comp.Attr.attribTree Attr.java:386 
        at com.sun.tools.javac.comp.Attr.attribExpr Attr.java:403 
        at com.sun.tools.javac.comp.Attr.visitReturn Attr.java:1183 
        at com.sun.tools.javac.tree.JCTree$JCReturn.accept JCTree.java:1220
Comment 1 unr303 2008-02-06 10:50:24 UTC
Created attachment 56152 [details]
ide log
Comment 2 unr303 2008-02-06 10:50:38 UTC
Created attachment 56153 [details]
dump file
Comment 3 unr303 2008-02-06 10:51:19 UTC
Was editing near
        public SaveAction() {
            putValue(COMMAND_KEY, COMMAND_VALUE);
        }
Comment 4 unr303 2008-03-20 16:57:20 UTC
invoked code completion for ToolBarPanel in
                    private void initContactPersonsToolBar(UnitsMap context) {
                        context.get(ViewUnit.class).get().getComponentByName(ToolBarPanel.,
                                componentName)
                    }
Comment 5 unr303 2008-03-20 16:57:50 UTC
Created attachment 58769 [details]
ide log
Comment 6 unr303 2008-03-20 16:59:38 UTC
Also after new Action[]{ in
                    private void initContactPersonsToolBar(UnitsMap context) {
                        context.get(ViewUnit.class).get().getComponentByName(ToolBarPanel.class,
                                OrganizationEntityForm.CONTACT_PERSONS_TOOLBAR).setActions(
                                new Action[]{
                        });
                    }
Comment 7 unr303 2008-03-21 08:11:05 UTC
Near createNewDetail() in
                    private void initContactPersonsToolBar(final UnitsMap context) {
                        ToolBarPanel toolBar = context.get(ViewUnit.class).get().getComponentByName(
                                ToolBarPanel.class,
                                OrganizationEntityForm.CONTACT_PERSONS_TOOLBAR);
                        toolBar.setActions(
                                new Action[]{
                                    new DefaultNewAction() {

                                        private static final long serialVersionUID = -1;

                                        @Override
                                        protected void performAction() {
                                            getBM(context).getContactPerson().getDetails().add(
                                                    getBM(context).getContactPerson().
                                                    createNewDetail());
                                        }

                                    },
                                    new DefaultDeleteAction() {

                                        private static final long serialVersionUID = -1;

                                        @Override
                                        protected void performAction() {
                                            throw new UnsupportedOperationException(
                                                    "Not supported yet.");
                                        }

                                    },
                                });
                    }
Comment 8 unr303 2008-03-21 08:12:02 UTC
Created attachment 58814 [details]
ide log
Comment 9 unr303 2008-03-21 09:42:37 UTC
invoking code complition for getConfiguration() (look for "getco")
Comment 10 unr303 2008-03-21 09:43:03 UTC
Created attachment 58818 [details]
full file source
Comment 11 unr303 2008-03-21 09:43:42 UTC
Created attachment 58819 [details]
ide log
Comment 12 unr303 2008-03-25 10:06:30 UTC
Created attachment 58977 [details]
dump
Comment 13 unr303 2008-03-25 10:07:05 UTC
Created attachment 58978 [details]
ide log
Comment 14 Dusan Balek 2008-03-28 15:27:19 UTC
Fixed.

changeset d7f65248c0b2 in main/nb-javac
details: http://hg.netbeans.org/main/nb-javac?cmd=changeset;node=d7f65248c0b2
changeset 7c479e14c4b5 in main
details: http://hg.netbeans.org/main?cmd=changeset;node=7c479e14c4b5
Comment 15 Jiri Rechtacek 2008-10-07 14:46:51 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200810060201)
Comment 16 Jan Becicka 2008-11-12 09:27:53 UTC

*** This issue has been marked as a duplicate of 138391 ***