This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 129564

Summary: Missing Feature for "Get Lock" and "Unlock" for subversion client
Product: versioncontrol Reporter: jwoelper <jwoelper>
Component: SubversionAssignee: issues@versioncontrol <issues>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Exception Reporter:

Description jwoelper 2008-03-07 16:54:58 UTC
For  - at least in our case - all projects that require handling of binary files, locking is required.
Other SVN clients offer a lock and unlock functionality. Lack of this totally prevents Netbeans from being usable with 
svn in our environment.
It is widely understood that merging line-based files is the new way to go with svn; however
there should be the possibility to work with the svn:needs-lock property with binary data.
Comment 1 Tomas Stupka 2008-03-07 18:44:29 UTC

*** This issue has been marked as a duplicate of 95177 ***