This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 132886

Summary: Missing info after the last StepOverExpression action
Product: debugger Reporter: Jiri Vagner <jvagner>
Component: JavaAssignee: Daniel Prusa <dprusa>
Status: CLOSED DUPLICATE    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Attachments: MemoryView.java
last-step-over-expression.png

Description Jiri Vagner 2008-04-15 14:17:02 UTC
Missing information about return values and params inside Local Variables view after the last StepOverExpression action.
See the screenshot.

Sample code: MemoryView.java, line 104

Steps to reproduce:
 - go to line 104, RunToCursor
 - run StepOverExpression action 5x
 - and StepOverExpression action again

Product Version: NetBeans IDE Dev (Build 200804150002)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)
Comment 1 Jiri Vagner 2008-04-15 14:17:47 UTC
Created attachment 60207 [details]
MemoryView.java
Comment 2 Jiri Vagner 2008-04-15 14:18:51 UTC
Created attachment 60208 [details]
last-step-over-expression.png
Comment 3 Daniel Prusa 2008-05-21 15:23:34 UTC
reproducible
Comment 4 Daniel Prusa 2009-10-12 15:48:03 UTC
This problem has been already reported in issue 100201, the identical piece of code is used there.

*** This issue has been marked as a duplicate of 100201 ***
Comment 5 Marian Mirilovic 2010-05-06 08:02:14 UTC
verified duplicate