This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 138326

Summary: IllegalStateException: Method must be invoked from EDT
Product: groovy Reporter: Lukas Jungmann <jungi>
Component: GrailsAssignee: Petr Hejl <phejl>
Status: VERIFIED FIXED    
Severity: blocker CC: tesa
Priority: P3    
Version: 6.x   
Hardware: All   
OS: Linux   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=69441
Issue Type: DEFECT Exception Reporter: 69441
Bug Depends on: 135670    
Bug Blocks:    

Description Lukas Jungmann 2008-06-26 10:31:58 UTC
Build: NetBeans IDE Dev (Build 20080624154200)
VM: Java HotSpot(TM) Client VM, 10.0-b22, Java(TM) SE Runtime Environment, 1.6.0_06-b02
OS: Windows XP, 5.1, x86
User comments: Trying to creat a new grails project. Error occures every time when clicking on finish.
STACKTRACE: (first 10 lines)
java.lang.IllegalStateException: Method must be invoked from EDT
        at org.netbeans.modules.extexecution.api.ExecutionService.run(ExecutionService.java:176)
        at org.netbeans.modules.extexecution.api.ExecutionService.run(ExecutionService.java:171)
        at
org.netbeans.modules.groovy.grailsproject.ui.wizards.NewGrailsProjectWizardIterator.instantiate(NewGrailsProjectWizardIterator.java:115)
        at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:1023)
        at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:595)
        at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:416)
        at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:253)
        at org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:165)
        at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1384)
        at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1341)
Comment 1 Lukas Jungmann 2008-06-26 10:45:07 UTC
seems to be reproducible only in trunk; works fine in 6.5M1 build...
Comment 2 Exceptions Reporter 2008-06-26 18:48:21 UTC
This issue has already 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=69441
Comment 3 martin_adamek 2008-06-26 19:05:25 UTC
As there are duplicates coming and people asking about this problem, i have just small advice/workaround: create Grails application in command line ('grails 
create-app someName') and then open it in NetBeans as any other NetBeans project (File -> Open Project). You don't need to do any import, NetBeans 
understands any existing Grails application.
Comment 4 Petr Hejl 2008-06-26 21:22:05 UTC
Workarounded in trunk ab27dd83f970. Lowering priority - leaving as reminder.
Comment 5 Petr Hejl 2008-07-07 21:31:40 UTC
Fixed by the change in extexecution.
Comment 6 Lukas Jungmann 2008-08-07 16:44:33 UTC
v.