This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 139771

Summary: netbeans ide 6.1 update problem: missing required modules : module.org.netbeans.modules.web.jspparsers/3 = 200805300101
Product: obsolete Reporter: mike_lee <mike_lee>
Component: visualwebAssignee: issues@obsolete <issues>
Status: NEW ---    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: PC   
OS: Linux   
Issue Type: TASK Exception Reporter:

Description mike_lee 2008-07-11 22:48:20 UTC
I am trying to update netbeans 6.1, however 2 of updates can not be installed:

platform   ver 1.1 -> 1.1.1
visual JSF  ver 1.1.1 -> 1.1.2


------------------------------------------------
error messages:

Missing required modules for plugin explorer & property sheet api:
jsp parser [module.org.netbeans.modules.web.jspparsers/3 = 200805300101]

Missing required modules for plugin jsp parser:
jsp parser [module.org.netbeans.modules.web.jspparsers/3 = 200805300101]

Missing required modules for plugin nodes api:
jsp parser [module.org.netbeans.modules.web.jspparsers/3 = 200805300101]

Missing required modules for plugin text api:
jsp parser [module.org.netbeans.modules.web.jspparsers/3 = 200805300101]
-------------------------------------



however, I checked netbeans-6.1/enterprise5/modules/org-netbeans-modules-web-jspparser.jar

it is  OpenIDE-Module-Implementation-Version: 200805300101

here is the manifex.mf:

---------------------------
Manifest-Version: 1.0

Ant-Version: Apache Ant 1.7.0

Created-By: 1.5.0_14-b03 (Sun Microsystems Inc.)

OpenIDE-Module-Public-Packages: org.netbeans.modules.web.jsps.parserap

 i.*

OpenIDE-Module-Friends: org.netbeans.modules.web.core, org.netbeans.mo

 dules.web.core.syntax, org.netbeans.modules.web.project

OpenIDE-Module-Module-Dependencies: org.netbeans.api.java/1, org.netbe

 ans.api.web.webmodule > 1.8, org.netbeans.libs.glassfish_logging/1 > 

 1.0, org.netbeans.libs.xerces/1 > 1.2, org.netbeans.modules.servletjs

 papi/1 > 1.0, org.netbeans.modules.xml.core/2, org.openide.filesystem

 s > 6.2, org.openide.loaders > 6.8, org.openide.modules > 6.2, org.op

 enide.nodes > 7.3, org.openide.text > 6.16, org.openide.util > 6.2, o

 rg.openide.windows > 6.19

OpenIDE-Module-Java-Dependencies: Java > 1.5

OpenIDE-Module-Implementation-Version: 200805300101

AutoUpdate-Show-In-Client: false

OpenIDE-Module: org.netbeans.modules.web.jspparser/3

OpenIDE-Module-Localizing-Bundle: org/netbeans/modules/web/jspparser/B

 undle.properties

OpenIDE-Module-Specification-Version: 3.1

OpenIDE-Module-Requires: org.openide.windows.IOProvider, org.openide.m

 odules.ModuleFormat1



---------------------------



thanks  & have a good weekend!

sincerely

mike