This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 140581

Summary: Mnemonics in conflict in JavaCode>Formating
Product: java Reporter: Petr Dvorak <joshis>
Component: EditorAssignee: Dusan Balek <dbalek>
Status: VERIFIED FIXED    
Severity: blocker Keywords: A11Y, SIMPLEFIX
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:

Description Petr Dvorak 2008-07-17 16:23:48 UTC
Go to Tools>Options, select Java Code, formatting Tab. Choose Wrapping from the combobox. There are 2 conflicts of
mnemonics:

1. &Assert ~ Method Call &Arguments
2. Assi&gnment Operators ~ Cate&gory
Comment 1 Dusan Balek 2008-07-25 12:06:57 UTC
After the recent changes to the Formatting Options dialog, it is very hard to find any mnemonics combination without
conflicts. Ondro, do we need mnemonics in Formatting Options dialog?
Comment 2 Dusan Balek 2008-07-25 12:11:38 UTC
*** Issue 140583 has been marked as a duplicate of this issue. ***
Comment 3 Dusan Balek 2008-07-25 12:13:30 UTC
Also go to Tools>Options, select Java Code, formatting Tab. Choose "Blank Lines" from the combobox. There is a conflict of
mnemonics:

After i&mports ~ Before &method
Comment 4 Ondrej Langr 2008-07-25 13:31:38 UTC
I suggest to simply remove mnemonics from:

Method Call &Arguments in "Wrapping" category
Assignment Operators in "Wrapping" category
After I&mports in "Blank Lines" category

This suggestion is based on Nb mnemonic rules (http://jupiter.czech.sun.com/wiki/view/Netbeans/NbMnemonicRules):
---
"When it is not feasible to provide mnemonics for all dialog box components, mnemonics can be skipped for less important
components if they can be easily and logically reached by tab traversal."
Comment 5 Jan Becicka 2008-07-25 13:39:48 UTC
Thanks, Ondro.
Comment 6 Dusan Balek 2008-11-19 10:05:06 UTC
Fixed.

changeset 1d35b2a0802b in main
details: http://hg.netbeans.org/main?cmd=changeset;node=1d35b2a0802b
Comment 7 Quality Engineering 2008-11-19 16:41:44 UTC
Integrated into 'main-golden', will be available in build *200811191401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1d35b2a0802b
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #140581: Mnemonics in conflict in JavaCode>Formating - fixed.
Comment 8 Petr Dvorak 2009-01-08 16:48:40 UTC
V.