This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 141678

Summary: Validity of new META-INF service class not checked
Product: apisupport Reporter: rmichalsky <rmichalsky>
Component: ProjectAssignee: rmichalsky <rmichalsky>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: P4    
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:

Description rmichalsky 2008-07-25 13:45:08 UTC
When adding new META-INF service via UI ("Add new service" action in META-INF services browser), newly added class
should be tested whether:
* it is a concrete class with no-arg ctor
* it implements given service interface
Comment 1 Jesse Glick 2008-10-30 21:51:41 UTC
Will be solved in the future by using annotations rather than an explicit registration.

*** This issue has been marked as a duplicate of 150447 ***