Bug 149563

Summary: org.netbeans.spi.server.ServerInstanceProvider is loaded during NetBeans startup with LimeWire project
Product: serverplugins Reporter: Alexander Kouznetsov <mrkam>
Component: GlassFishAssignee: _ pcw <pcw>
Status: VERIFIED DUPLICATE    
Severity: blocker CC: issues, jtulach
Priority: P3 Keywords: PERFORMANCE, TEST
Version: 6.x   
Hardware: PC   
OS: Windows XP   
URL: http://wiki.netbeans.org/FitnessViaWhiteAndBlackList
Issue Type: DEFECT Exception Reporter:
Attachments: Stacktraces

Description Alexander Kouznetsov 2008-10-08 20:33:08 UTC
Performance whitelist test reports that following classes are loaded during NetBeans startup with LimeWire project:

org.netbeans.spi.server.ServerInstanceProvider

Please don't load these classes unless they are really necessary. More information about the test available via the URL
specified.

Comment from jtulach: 
Called from: 
org.netbeans.modules.glassfish.spi.ServerUtilities.getServerProvider(ServerUtilities.java:167)          
org.netbeans.modules.glassfish.javaee.Hk2OptionalFactory.finishServerInitialization(Hk2OptionalFactory.java:268)
Imho it is not OK to "finishServerInitialization" during start of non web 
project.
Comment 1 Alexander Kouznetsov 2008-10-08 20:33:39 UTC
Created attachment 71412 [details]
Stacktraces
Comment 2 Petr Hejl 2008-10-08 20:37:38 UTC

*** This issue has been marked as a duplicate of 148177 ***
Comment 3 Alexander Kouznetsov 2008-10-09 09:57:42 UTC
verified