This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 149666

Summary: NullPointerException at com.sun.tools.javac.comp.Attr.visitIdent
Product: java Reporter: stefan79 <stefan79>
Component: CompilerAssignee: Dusan Balek <dbalek>
Status: RESOLVED FIXED    
Severity: blocker CC: tzezula
Priority: P3 Keywords: RANDOM
Version: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=125716
Issue Type: DEFECT Exception Reporter: 125716
Bug Depends on:    
Bug Blocks: 152191    
Attachments: stacktrace
Message-Log (is incomplete because I need the begin of the message)

Description stefan79 2008-10-09 17:56:59 UTC
Build: NetBeans IDE Dev (Build 200810090201)
VM: Java HotSpot(TM) Client VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Windows XP, 5.1, x86

User Comments:
stefan79: NPE after confirming a Code-Completion (called with Ctrl-Space)



Stacktrace: 
java.lang.NullPointerException
        at com.sun.tools.javac.comp.Attr.visitIdent(Attr.java:1865)
        at com.sun.tools.javac.tree.JCTree$JCIdent.accept(JCTree.java:1683)
        at com.sun.tools.javac.comp.Attr.attribTree(Attr.java:391)
        at com.sun.tools.javac.comp.Attr.attribExpr(Attr.java:415)
        at com.sun.tools.javac.comp.Attr.visitBinary(Attr.java:1712)
        at com.sun.tools.javac.tree.JCTree$JCBinary.accept(JCTree.java:1543)
Comment 1 stefan79 2008-10-09 17:57:04 UTC
Created attachment 71487 [details]
stacktrace
Comment 2 Petr Dvorak 2008-10-09 18:11:53 UTC
Hi! Can you please provide more details about this issue? Could you please attach your "messages.log" file (C:\Documents
and settings\<user>\.netbeans\<version>\var\log)? Are you able to reproduce the NullPointerException (if yes, please
give us numbered steps or the file that is causing the troubles)?
Comment 3 stefan79 2008-10-09 18:26:07 UTC
Created attachment 71493 [details]
Message-Log (is incomplete because I need the begin of the message)
Comment 4 stefan79 2008-10-09 18:35:43 UTC
Can´t Reproduce it.
Comment 5 Dusan Balek 2008-10-09 21:39:37 UTC
Tome - look at it please - thrown from reattrMethodBody,
Comment 6 stefan79 2010-04-28 10:52:13 UTC
Too old and doesn´t occurred again in 6.8 final.