This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 150750

Summary: Folders briefly show hidden entries on file creation/deletion
Product: platform Reporter: matthies <matthies>
Component: ExplorerAssignee: t_h <t_h>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Exception Reporter:

Description matthies 2008-10-20 17:35:03 UTC
This is very similar to issue 144718.
Repro:
1) Select and expand a source folder which contains some hidden entries such as a CVS sub-folder or .#* files.
2) On the folder, choose New -> Java Class... (for example) in the context menu.
3) Press Finish.
The result is that all the hidden entries are shown as blank items for a second or so, which as in issue 144718 creates 
an unpleasant visual "bounce" effect, which gives the false impression that there's much more going on than just a 
simple file being created.

Product Version: NetBeans IDE Dev (Build 200810181401)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 1 matthies 2008-10-20 17:37:08 UTC
PS: As with issue 144718, this seems to be only reproducible once for any given folder (per NetBeans session).
Comment 2 matthies 2008-10-22 16:14:56 UTC
Same effect when deleting a file.

I just had this hapen to me on a folder with ~30 hidden files, which looks atrocious as almost the whole treeview 
appears to be replaced by a long list of blank items for a second or two.
Comment 3 David Simonek 2008-10-24 10:35:51 UTC
I guess reporter talks about projects view, but this looks to me as general explorer issue, passing there, please
reassign if I'm wrong, thanks.
Comment 4 matthies 2008-10-24 14:30:37 UTC
Both in Files and Projects view. Generally I work more with the Files view than with the Projects view.
Comment 5 t_h 2008-10-29 14:56:54 UTC
This problem was probably introduced in 93a01020bf5a where FileObject was replaced by FolderChildrenPair which is used
as key for FolderChildren. The problem is that each time setKeys() is called, the key for hidden file (e.g. file
beginning with .) is different (seq. number in FolderChildrenPair is increased). It should be resolved by fixing issue
150747.

*** This issue has been marked as a duplicate of 150747 ***