This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 157380

Summary: provide ability to run a main method from a standalone jar file
Product: java Reporter: emiddio <emiddio>
Component: ProjectAssignee: Jan Jancura <jjancura>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: All   
OS: Windows XP   
Issue Type: ENHANCEMENT Exception Reporter:

Description emiddio 2009-01-23 20:57:03 UTC
within a project with source code you can via project/properties/run -- choose a main method, args, etc.

sometimes i have a jar file i want to run a main method from -- but no source code -- i would like to be able to
go something similar to what can be done with a project with source -- get a dialog with list of mains i could
run and ability to set args -- then run the class -- without source code being present.
Comment 1 Jesse Glick 2009-07-07 21:11:01 UTC

*** This issue has been marked as a duplicate of 34377 ***