This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 159987

Summary: AssertionError: Got null return from getMenuPresenter in org.netbeans.modules.editor.MainMenuAction$PasteFormattedAction@377358
Product: editor Reporter: Egor Ushakov <gorrus>
Component: Actions/Menu/ToolbarAssignee: issues@editor <issues>
Status: RESOLVED DUPLICATE    
Severity: blocker CC: ca-nb, esmithbss, jblume, jglick, jsedek, nigel_bris, tboudreau, thetamind
Priority: P3 Keywords: SIMPLEFIX
Version: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=147403
Issue Type: DEFECT Exception Reporter: 147403
Attachments: stacktrace
stacktrace
stacktrace
stacktrace
stacktrace

Description Egor Ushakov 2009-03-10 11:53:43 UTC
Build: NetBeans IDE Dev (Build 200903091401)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) Platform, Standard Edition for Business, 1.6.0_10-b33
OS: SunOS, 5.11, x86

Stacktrace: 
java.lang.AssertionError: Got null return from getMenuPresenter in org.netbeans.modules.editor.MainMenuAction$PasteFormattedAction@377358
        at org.netbeans.modules.editor.MainMenuAction.setMenu(MainMenuAction.java:198)
        at org.netbeans.modules.editor.MainMenuAction.resultChanged(MainMenuAction.java:112)
        at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:111)
        at org.openide.util.lookup.SimpleProxyLookup.access$000(SimpleProxyLookup.java:58)
        at org.openide.util.lookup.SimpleProxyLookup$ProxyResult.checkResult(SimpleProxyLookup.java:183)
        at org.openide.util.lookup.SimpleProxyLookup$ProxyResult.allInstances(SimpleProxyLookup.java:255)
Comment 1 Egor Ushakov 2009-03-10 11:53:48 UTC
Created attachment 77968 [details]
stacktrace
Comment 2 Vitezslav Stejskal 2009-03-11 15:59:40 UTC
It looks like that the changes fired from lookup may arrive even before MainMenuAction subclasses are fully initialized.
IMO easy to fix.
Comment 3 Jiri Prox 2009-03-16 18:14:34 UTC
*** Issue 160130 has been marked as a duplicate of this issue. ***
Comment 4 Jindrich Sedek 2009-03-17 11:22:02 UTC
Build: NetBeans IDE Dev (Build 20090317073347)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b02
OS: SunOS, 5.11, x86

User Comments: 
AE was thrown during NetBeans startup

Stacktrace: 
java.lang.AssertionError: Got null return from getMenuPresenter in org.netbeans.modules.editor.MainMenuAction$PasteFormattedAction@a16e60
        at org.netbeans.modules.editor.MainMenuAction.setMenu(MainMenuAction.java:198)
        at org.netbeans.modules.editor.MainMenuAction.resultChanged(MainMenuAction.java:112)
        at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:111)
        at org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:152)
        at org.netbeans.modules.openide.windows.GlobalActionContextImpl.propertyChange(GlobalActionContextImpl.java:134)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
Comment 5 Jindrich Sedek 2009-03-17 11:22:12 UTC
Created attachment 78288 [details]
stacktrace
Comment 6 Jesse Glick 2009-03-18 17:09:17 UTC
Build: NetBeans IDE Dev (Build 090318)
VM: Java HotSpot(TM) Client VM, 1.5.0_15-b04, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_15-b04
OS: Linux, 2.6.27-11-generic, i386

User Comments: 
Just started IDE on a fresh userdir and opened Services tab.

Stacktrace: 
java.lang.AssertionError: Got null return from getMenuPresenter in org.netbeans.modules.editor.MainMenuAction$PasteFormattedAction@b4fa48
        at org.netbeans.modules.editor.MainMenuAction.setMenu(MainMenuAction.java:198)
        at org.netbeans.modules.editor.MainMenuAction.resultChanged(MainMenuAction.java:112)
        at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:111)
        at org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:152)
        at org.netbeans.modules.openide.windows.GlobalActionContextImpl.propertyChange(GlobalActionContextImpl.java:134)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:333)
Comment 7 Jesse Glick 2009-03-18 17:09:33 UTC
Created attachment 78396 [details]
stacktrace
Comment 8 esmithbss 2009-03-18 19:46:46 UTC
Build: NetBeans IDE Dev (Build 200903170201)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 
Just installed NB Nightly and upon first launch found an old project listed under Projects (from a previous dev version install).

Moved mouse up to project and clicked on the mouse button for a pull-down menu to delete the project.

Stacktrace: 
java.lang.AssertionError: Got null return from getMenuPresenter in org.netbeans.modules.editor.MainMenuAction$PasteFormattedAction@1b0ecf4
        at org.netbeans.modules.editor.MainMenuAction.setMenu(MainMenuAction.java:198)
        at org.netbeans.modules.editor.MainMenuAction.resultChanged(MainMenuAction.java:112)
        at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:111)
        at org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:152)
        at org.netbeans.modules.openide.windows.GlobalActionContextImpl.propertyChange(GlobalActionContextImpl.java:134)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
Comment 9 esmithbss 2009-03-18 19:46:50 UTC
Created attachment 78405 [details]
stacktrace
Comment 10 Andrei Chistiakov 2009-03-19 09:51:40 UTC
Build: NetBeans IDE Dev (Build 200903181604)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b02
OS: Windows XP, 5.1, x86

User Comments: 
just started NetBeans

Stacktrace: 
java.lang.AssertionError: Got null return from getMenuPresenter in org.netbeans.modules.editor.MainMenuAction$PasteFormattedAction@1c8b26e
        at org.netbeans.modules.editor.MainMenuAction.setMenu(MainMenuAction.java:198)
        at org.netbeans.modules.editor.MainMenuAction.resultChanged(MainMenuAction.java:112)
        at org.openide.util.lookup.SimpleProxyLookup.checkLookup(SimpleProxyLookup.java:111)
        at org.openide.util.lookup.SimpleProxyLookup.lookup(SimpleProxyLookup.java:152)
        at org.netbeans.modules.openide.windows.GlobalActionContextImpl.propertyChange(GlobalActionContextImpl.java:134)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
Comment 11 Andrei Chistiakov 2009-03-19 09:51:46 UTC
Created attachment 78426 [details]
stacktrace
Comment 12 Vitezslav Stejskal 2009-03-23 12:43:45 UTC
Should already be fixed, see issue #160273.

*** This issue has been marked as a duplicate of 160273 ***