This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 162553

Summary: AssertionError at org.netbeans.modules.csl.core.GsfHtmlFormatter.parameters
Product: editor Reporter: blakenzoe <blakenzoe>
Component: CSL (API & infrastructure)Assignee: David Strupl <dstrupl>
Status: RESOLVED FIXED    
Severity: blocker Keywords: SIMPLEFIX
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=149440
Issue Type: DEFECT Exception Reporter: 149440
Attachments: stacktrace

Description blakenzoe 2009-04-14 06:10:48 UTC
Build: NetBeans IDE Dev (Build 200904100201)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Windows Vista, 6.0, x86

User Comments:
blakenzoe: Editing a JavaScript function based on the jQuery framework.



Stacktrace: 
java.lang.AssertionError
        at org.netbeans.modules.csl.core.GsfHtmlFormatter.parameters(GsfHtmlFormatter.java:123)
        at org.netbeans.modules.javascript.editing.JsAnalyzer$JsStructureItem.getHtml(JsAnalyzer.java:982)
        at org.netbeans.modules.csl.navigation.ElementNode.getHtmlDisplayName(ElementNode.java:134)
        at org.openide.explorer.view.VisualizerNode.getHtmlDisplayName(VisualizerNode.java:566)
        at org.openide.explorer.view.NodeRenderer.getTreeCellRendererComponent(NodeRenderer.java:125)
        at javax.swing.plaf.basic.BasicTreeUI$NodeDimensionsHandler.getNodeDimensions(BasicTreeUI.java:2717)
Comment 1 blakenzoe 2009-04-14 06:10:54 UTC
Created attachment 80017 [details]
stacktrace
Comment 2 Vitezslav Stejskal 2009-04-20 20:07:21 UTC
*** Issue 162556 has been marked as a duplicate of this issue. ***
Comment 3 Vitezslav Stejskal 2009-04-20 20:50:32 UTC
IMO a race condition in ElementNode.FORMATTER.
Comment 4 David Strupl 2009-04-28 13:51:34 UTC
Fixed in jet-main by changeset   : 128943:548a32999a84