This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 163989

Summary: NullPointerException at com.sun.tools.javac.comp.Attr.visitSelect
Product: java Reporter: nvaidyan <nvaidyan>
Component: CompilerAssignee: Dusan Balek <dbalek>
Status: RESOLVED FIXED    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
URL: http://statistics.netbeans.org/exceptions/detail.do?id=150258
Issue Type: DEFECT Exception Reporter: 150258
Attachments: stacktrace

Description nvaidyan 2009-04-29 00:22:03 UTC
Build: NetBeans IDE Dev (Build 200904011705)
VM: Java HotSpot(TM) 64-Bit Server VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows Vista, 6.0, amd64

Stacktrace: 
java.lang.NullPointerException
        at com.sun.tools.javac.comp.Attr.visitSelect(Attr.java:1914)
        at com.sun.tools.javac.tree.JCTree$JCFieldAccess.accept(JCTree.java:1655)
        at com.sun.tools.javac.comp.Attr.attribTree(Attr.java:381)
        at com.sun.tools.javac.comp.Attr.visitSelect(Attr.java:1886)
        at com.sun.tools.javac.tree.JCTree$JCFieldAccess.accept(JCTree.java:1655)
        at com.sun.tools.javac.comp.Attr.attribTree(Attr.java:381)
Comment 1 nvaidyan 2009-04-29 00:22:14 UTC
Created attachment 81138 [details]
stacktrace
Comment 2 Dusan Balek 2009-05-05 08:16:09 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/da9eb37ee0df

changeset b3befa7d9c31 in main/nb-javac
details: http://hg.netbeans.org/main/nb-javac?cmd=changeset;node=b3befa7d9c31
Comment 3 Quality Engineering 2009-05-07 07:49:59 UTC
Integrated into 'main-golden', will be available in build *200905070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/da9eb37ee0df
User: Dusan Balek <dbalek@netbeans.org>
Log: Issues #146205, #153664, #161870, #161915, #162097, #162302, #162451, #163931, and #163989 fixed.
Comment 4 Dusan Balek 2009-06-18 10:39:21 UTC
*** Issue 166387 has been marked as a duplicate of this issue. ***
Comment 5 Dusan Balek 2009-06-18 10:42:09 UTC
*** Issue 148754 has been marked as a duplicate of this issue. ***