This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 180606

Summary: Class moving throws NPE The fileObject parameter cannot be null
Product: javafx Reporter: Alexandr Scherbatiy <sunflower>
Component: UnsupportedAssignee: J Bachorik <yardus>
Status: VERIFIED FIXED    
Severity: normal    
Priority: P2    
Version: 6.x   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 173077, 180481    
Attachments: IDE log file

Description Alexandr Scherbatiy 2010-02-11 05:23:46 UTC
NetBeans-JavaFX-Soma: #149

  Product Version         = NetBeans IDE Dev (Build 201002100200) (#c9e315a9e48e)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_15; Java HotSpot(TM) Client VM 14.1-b02; Sun Microsystems Inc.


Steps to reproduce:


- Open the attached project 
https://netbeans.org/bugzilla/attachment.cgi?id=93747

- Move the class mathematics.multidimensional.AMDVector to a
 mathematics.multidimensional.vector package
- Move the class  mathematics.multidimensional.MDVector to the 
  mathematics.multidimensional.vector package

The NPE pops up:


java.lang.NullPointerException: The fileObject parameter cannot be null
	at org.openide.util.Parameters.notNull(Parameters.java:86)
	at org.openide.filesystems.FileUtil.isParentOf(FileUtil.java:1514)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator.mergeParents(FXErrorAnnotator.java:353)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator.doProcess(FXErrorAnnotator.java:332)
	at org.netbeans.modules.javafx.source.tasklist.FXErrorAnnotator.process(FXErrorAnnotator.java:257)
	at org.netbeans.modules.javafx.source.indexing.JavaFXIndexer.index(JavaFXIndexer.java:583)
	at org.netbeans.modules.parsing.spi.indexing.Indexable$MyAccessor$3.run(Indexable.java:205)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.runIndexer(RepositoryUpdater.java:231)
	at org.netbeans.modules.parsing.spi.indexing.Indexable$MyAccessor.index(Indexable.java:203)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work$3.run(RepositoryUpdater.java:1883)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:129)
	at org.netbeans.modules.parsing.api.ParserManager$UserTaskAction.run(ParserManager.java:113)
	at org.netbeans.modules.parsing.impl.TaskProcessor.runUserTask(TaskProcessor.java:190)
	at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:99)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.indexEmbedding(RepositoryUpdater.java:1856)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doIndex(RepositoryUpdater.java:1695)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.access$1200(RepositoryUpdater.java:1403)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work$2.run(RepositoryUpdater.java:1571)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work$2.run(RepositoryUpdater.java:1569)
	at org.netbeans.modules.parsing.impl.indexing.errors.TaskCache.refreshTransaction(TaskCache.java:450)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.index(RepositoryUpdater.java:1569)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.scanFiles(RepositoryUpdater.java:1927)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$FileListWork.getDone(RepositoryUpdater.java:2105)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:1973)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:3554)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.run(RepositoryUpdater.java:3496)
	at org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:574)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
[catch] at java.lang.Thread.run(Thread.java:619)
Comment 1 Alexandr Scherbatiy 2010-02-11 05:24:41 UTC
Created attachment 94077 [details]
IDE log file
Comment 2 J Bachorik 2010-03-05 08:00:28 UTC
fixed http://hg.netbeans.org/javafx/rev/ac815b1f47cd
Comment 3 Alexandr Scherbatiy 2010-03-09 08:20:23 UTC
Unable to reproduce the issue in build NetBeans-JavaFX-Soma:  #179