This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 187325

Summary: Undo of DnD in editor does not behave well
Product: editor Reporter: ulfzibis <ulfzibis>
Component: -- Other --Assignee: Milutin Kristofic <mkristofic>
Status: RESOLVED DUPLICATE    
Severity: normal CC: dstrupl
Priority: P4    
Version: 6.x   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Exception Reporter:
Attachments: log file
Screen shot
Screenshot 2
log file

Description ulfzibis 2010-06-08 12:39:06 UTC
[ BUILD # : RC 2 ]
[ JDK VERSION : 1.6.18 ]

- open properties file from nbproject/config
- make some changes and save
- hit undo 1 or more times
--> editor tab label doesn't change to bold (=modified)
--> save action remains disabled
--> Run Project ignores the reverted changes
Comment 1 David Strupl 2010-06-10 08:03:20 UTC
I have just tried to edit file nbproject/project.properties. Works like a charm for me. Can you please tell for what file it did not work for you (in what project type)? Closing as works for me for now, after adding more details please reopen. I was testing wih NB 6.9 RC2 on Win XP in an attempt to match your config.

Also any exceptions in the log file?
Comment 2 ulfzibis 2010-06-10 13:17:57 UTC
Created attachment 99979 [details]
log file

(In reply to comment #1)
> I have just tried to edit file nbproject/project.properties. Works like a charm
> for me. Can you please tell for what file it did not work for you
As I said: properties file in *config* folder (here: parse_UnicodeSpec).

> (in what project type)?
 Java SE (same than for bug 187407)

> I was testing wih NB 6.9 RC2 on Win XP in an attempt to match your config.
That's correct.

> Also any exceptions in the log file?
see attachment.
Comment 3 ulfzibis 2010-06-10 13:21:05 UTC
Maybe you have to once run the project, before the undo ?
Comment 4 David Strupl 2010-06-10 14:24:22 UTC
There is some exception from the SVN - are you able to reproduce the problem after start (when the exception from SVN doesn't happen)?

I have tried with a file under configs folder and I am still not able to reproduce....

I have checked out your project (trunk version) and don't see the problem. BTW were you using the config when you were trying to edit it?
Comment 5 ulfzibis 2010-06-14 07:11:57 UTC
Created attachment 100048 [details]
Screen shot

Started here shortly after new NB startup
Comment 6 ulfzibis 2010-06-14 07:15:22 UTC
After:
- run project
- move comment '#' to other line by mouse drag 'n drop:
#application.args= make/tools/UnicodeData/UnicodeData.txt
application.args= -v make/tools/UnicodeData/UnicodeData.txt 14
#application.args= -v make/tools/UnicodeData/UnicodeData.txt -1
main.class=build.tools.generatecharacter.UnicodeSpec
run.jvmargs=

- save all
- run project
Comment 7 ulfzibis 2010-06-14 07:17:22 UTC
Created attachment 100049 [details]
Screenshot 2

After undo
Comment 8 ulfzibis 2010-06-14 07:24:19 UTC
BTW:
2nd time I tried UnDo while "checking for external changes". In this case, editor tab label was changed to bold and save action was enabled correctly.

> I have checked out your project (trunk version) and don't see the problem.
Don't use trunk, use branches/JDK-7/j_l_Character_names/

> BTW were you using the config when you were trying to edit it?
Don't if I understand correct, I use it to run main.class=build.tools.generatecharacter.UnicodeSpec
Comment 9 ulfzibis 2010-06-14 07:28:42 UTC
Created attachment 100050 [details]
log file
Comment 10 David Strupl 2010-10-22 08:23:10 UTC
Ulf, do you plan to work on this?
Comment 11 ulfzibis 2010-10-22 15:19:35 UTC
(In reply to comment #10)
Hm, what you mean by "work on this"?
Comment 12 David Strupl 2010-11-05 15:04:52 UTC
You have assigned it it to yourself - who else should work on it if not you? Work = try to fix/resolve etc ...
Comment 13 ulfzibis 2010-11-05 16:37:26 UTC
(In reply to comment #12)
> You have assigned it it to yourself ...
Oops, I see. I'm afraid, the assignee was changed automatically when I reopened.
Comment 14 David Strupl 2010-11-10 16:28:40 UTC
Ulf, is this problem somehow related to
https://netbeans.org/bugzilla/show_bug.cgi?id=60560
?

Are you able to reproduce the bad behavior without using mouse?

I am sorry but I still kind of don't understand the steps you are taking and thus I am not really able to reproduce the problem you are talking about.
Comment 15 David Strupl 2010-11-18 14:26:46 UTC
Ulf, can you please create for me a step by step instructions how to get to some wrong behaviour of the IDE? Marking as worksforme for now - please reopen after further explanation. I apologize for being a bit slow but reading the description and the comments does not lead me to steps to see the problem here on my machine.
Comment 16 ulfzibis 2010-11-19 20:30:59 UTC
(In reply to comment #14)
> Ulf, is this problem somehow related to
> https://netbeans.org/bugzilla/show_bug.cgi?id=60560 ?
I don't think so, because I'm aware of double-striking the UnDo.

But I guess, there might be some relation to bug 144073.

> Are you able to reproduce the bad behavior without using mouse?
Very good catch!
When I use Shift-right_arrow to mark the '#' and then Ctr-X + arrow + Ctrl-V + Shift-Ctrl-S, and after use the UnDo-button, the editor tab correctly becomes bold.
The error only occurs, if I use drag-'n-drop by mouse.

> I am sorry but I still kind of don't understand the steps you are taking and
> thus I am not really able to reproduce the problem you are talking about.
I don't know, how to explain better. Maybe the following is important:
- do all by mouse, if possible
- project must be main
- don't close the StartPage tab, or at least one other file must be open
- before opening the prop file, fist run the project with configuration "parse_UnicodeSpec"
- after doing the change + save, this time I didn't run the project again, but I could reproduce the bug as same.


Now I used 6.9 updated with patch 1:
Product Version: NetBeans IDE 6.9 (Build 201006101454)
Java: 1.6.0_20; Java HotSpot(TM) Client VM 16.3-b01
System: Windows XP version 5.1 running on x86; Cp1252; de_DE (nb)

target platform is JDK1.7.0_fastdebug_b84

Thanks for your patience.
Comment 17 David Strupl 2011-07-11 08:53:57 UTC
1. Move some text with mouse
2. Save
3. try to undo the move
Comment 18 Milutin Kristofic 2011-09-20 09:42:17 UTC

*** This bug has been marked as a duplicate of bug 60560 ***