This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 188228

Summary: Importer for Editor Formattings from Eclipse
Product: editor Reporter: tomzi <tomzi>
Component: Formatting & IndentationAssignee: Dusan Balek <dbalek>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 6.x   
Hardware: PC   
OS: Windows XP   
Issue Type: ENHANCEMENT Exception Reporter:
Attachments: Example template usually to be imported into eclipse

Description tomzi 2010-06-30 08:16:33 UTC
Created attachment 100510 [details]
Example template usually to be imported into eclipse

Please add functionality to import formatter exports from eclipse into netbeans. Our company has strict formatting requirements. We have templates that should be imported into the ide but none for netbeans so far. It would be a great helper to be able to import those formatting templates also into netbeans
Comment 1 Vitezslav Stejskal 2010-07-09 07:22:00 UTC
Thanks for the tip. Btw. do you know that you can load project specific formatting settings from other project? Eg. in project > properties > Formatting > Use project specific options > Load from other project. I know that this is not as convenient as exporting/importing formatting profiles, but it might help.
Comment 2 eda 2014-03-03 18:56:10 UTC
Is this the same as bug #188228 ?
Comment 3 markiewb 2015-04-06 19:58:32 UTC

*** This bug has been marked as a duplicate of bug 197876 ***