This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 194810

Summary: Opening C/C++ file starts parsing of 188 js files
Product: javascript Reporter: Alexander Simon <alexvsimon>
Component: EditorAssignee: Martin Fousek <marfous>
Status: RESOLVED FIXED    
Severity: normal CC: issues, tzezula, vv159170
Priority: P3 Keywords: PERFORMANCE
Version: 7.0   
Hardware: PC   
OS: Solaris   
Issue Type: DEFECT Exception Reporter:

Description Alexander Simon 2011-01-28 13:27:04 UTC
Steps to reproduce:
- start IDE from fresh user dir
- create C/C++ application
- open main.cpp file in editor
Actual behavior:
- Scanning projects progress bar
- Indexing 188 *.js files ( like to: jar:file:/export/home/as204739/cnd-main/nbbuild/netbeans/ide/jsstubs/allstubs.zip!//stub_dom2_HTMLHtmlElement.js)
Expected behavior:
- No indexing of *.js files.
Comment 1 Tomas Zezula 2011-01-28 13:32:09 UTC
Parsing api parses only registered roots.
The java script stubs are registered by javascript support when always when first project is opened as the javascript can be part of any project.
Comment 2 Petr Hejl 2012-09-18 13:08:53 UTC
Should be reevaluated for 7.3.
Comment 3 Martin Fousek 2012-09-21 07:17:43 UTC
Due to also issue #218708 I tried to move the GlobalPathRegistry registry to the JsLanguage#getLexerLanguage(). It's a hack but since the registration happens in JsLanguage, it always was. :/ This should be entry point for all JS features and on the other hand it's not called immediately after any project opening.

Hard to guess if it will behave correctly in all cases, it worked to me well at least for languages which embed JS, for plain JS, with empty userdir, tests. We have probably enough of time to figure out if that solution is stable and flawless enough.

web-main #536fe324d2c0
Comment 4 Martin Fousek 2012-10-11 06:04:13 UTC
*** Bug 206671 has been marked as a duplicate of this bug. ***