This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 19603

Summary: need more context when in XML tree view
Product: xml Reporter: _ jrichard <jrichard>
Component: Tree-EditAssignee: issues@xml <issues>
Status: RESOLVED WONTFIX    
Severity: blocker CC: dpavlica
Priority: P3 Keywords: UI
Version: 3.x   
Hardware: Sun   
OS: Solaris   
Issue Type: ENHANCEMENT Exception Reporter:
Bug Depends on: 26479    
Bug Blocks:    

Description _ jrichard 2002-01-19 01:09:28 UTC
The XML Tree view is great, it is actually better than some
other tree based XML editors that I've used.  It
is great to select pieces of a tree and move it around.
I also like adding tags without having to figure out
exactly where the end tag belongs. But...

It could be better if there were some way to give me
more context of the XML file that I'm editing.  I'm normally
editing XSLT files, and it really isn't enough to only know 
the names of the tags + the attribute of the currently 
selected element (as is shown now).  I can't (without a lot
of effort) figure out exactly where I am in my XML.

I'm not sure exactly what sort of GUI would be better, but
here are some ideas:
  -- show more information in the tree, maybe put some of the elements in the
     tree next to the node
  -- make the tree more like the JTreeTable, with attributes in the right
     column and tree in the left
  -- have a split view showing the tree on top and the text editor 
     with the XML on the bottom, the text editor could highlight the
     currently selected node in the tree.  (I think this would be the
     best of the three.)

Any of these might help give me more context while I'm editing.
Comment 1 Dennis Daniels 2002-02-10 11:25:19 UTC
for example when editing an xsl in tree view
name of the attribute appears in the left column, the values in the 
right
enabling a browse to the target xml would be very very nice.
This could be loaded into the dom so only values that match the 
dtd/xsd would be displayed in the value column
Comment 2 _ pkuzel 2002-06-03 12:27:04 UTC
Let these are considered while planning next release.
Comment 3 Marek Grummich 2002-07-19 16:17:48 UTC
Target milestone was changed from not determined to TBD
Comment 4 _ pkuzel 2002-08-14 17:14:55 UTC
*** Issue 22976 has been marked as a duplicate of this issue. ***
Comment 5 _ pkuzel 2003-03-14 19:22:42 UTC
Semantics editors are the way to follow. As the first step there is
experimental feature of customizable Visual XML editor.
Comment 6 zikmund 2005-05-04 15:19:40 UTC
XML tree editor is not part of NetBeans since 3.5 version. No plans to bring it
back.