This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 199722

Summary: Preview Desing -> Metal shows jCheckbox incorrectly
Product: guibuilder Reporter: asenk
Component: CodeAssignee: issues@guibuilder <issues>
Status: NEW ---    
Severity: normal    
Priority: P4    
Version: 7.0.1   
Hardware: PC   
OS: Linux   
Issue Type: DEFECT Exception Reporter:
Attachments: Screenshot

Description asenk 2011-06-27 09:34:28 UTC
Product Version: NetBeans IDE 7.0.1 RC1 (Build 201106222100)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b16
System: Linux version 2.6.38-8-generic running on i386; UTF-8; en_US (nb)

Setup Start IDE with clean userdir. Create seom J2SE project. Inside this project create some JFrameForm file.

1.Add JCheckbox into form
2.Preview Desing -> Metal

Result: Only text part of JCheckbox is shown. There is no box to check.
Comment 1 Jan Stola 2011-06-27 09:54:44 UTC
I am sorry, I am not able to reproduce this problem on JDK 1.7.0-ea-b145 on Windows. Could you, please, attach some screenshot? It would be also nice if you can investigate this problem more thoroughly, i.e., find out whether this problem occurs on Linux only, whether it is specific to some JDK build and whether there are similar problems with other components. Thank you in advance.
Comment 2 Jan Stola 2011-06-27 10:00:18 UTC
What look and feel NetBeans use when you are able to reproduce this problem? Are you able to reproduce this problem when NetBeans run on another look and feel?
Comment 3 asenk 2011-06-27 10:34:21 UTC
Created attachment 109124 [details]
Screenshot
Comment 4 asenk 2011-06-27 10:37:23 UTC
Product Version: NetBeans IDE 7.0.1 RC1 (Build 201106202100)
Java: 1.6.0_26; Java HotSpot(TM) Client VM 20.1-b02
System: Linux version 2.6.38-8-generic running on i386; UTF-8; en_US (nb)

Reproducible even with JDK6 and with older NB build.

This bug is not reproducible on Windows. (I use same JDKs on win).
Comment 5 asenk 2011-06-27 10:50:59 UTC
NB uses GTK+ L&F. With other L&F (Metal, Nimbus, Motif) this bug is not reproducible.
Comment 6 asenk 2011-07-27 11:59:01 UTC
I cannot reproduce this bug on:

Product Version: NetBeans IDE 7.0.1 (Build 201107211357)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b16
System: Linux version 2.6.38-10-generic running on i386; UTF-8; en_US (nb)

Closing as worksforme.
Comment 7 asenk 2011-09-14 10:49:47 UTC
Product Version: NetBeans IDE Dev (Build 201109132156)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Linux version 2.6.38-11-generic running on i386; UTF-8; en_US (nb)

This bug occurs again in Build 201109132156.