This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 204754

Summary: [WSphere] org.netbeans.modules.schema2beans.Schema2BeansException: Doc root 'applicationbnd:ApplicationBinding' not found in the DOM graph! Found '
Product: serverplugins Reporter: tnleeuw <tnleeuw>
Component: WebSphereAssignee: Petr Hejl <phejl>
Status: NEW ---    
Severity: normal    
Priority: P3    
Version: 7.1   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter: 145076
Attachments: stacktrace

Description tnleeuw 2011-11-07 10:13:04 UTC
This issue was reported manually by mmirilovic.
It already has 20 duplicates 

Build: NetBeans IDE Dev (Build 201110290600)
VM: Java HotSpot(TM) Client VM, 20.4-b02, Java(TM) SE Runtime Environment, 1.6.0_29-b11
OS: Windows Vista

User Comments:
tnleeuw: During search fase of global search-and-replace over all open projects

tnleeuw: Tried to select WebSphere 6.1 as run-target for an EAR Maven project

tnleeuw: This exception occurred when trying to find a string across all open projects in all js, jsp, and java files.

The offending file which tripped over NetBeans is an XML file which has lived in one of our projects since ages.

This error is a regression.

Similar problems started happening sometimes since August, I think.

The offending XML file is a WebSphere specfic file for the EAR deployment descriptors.

Since it's an XML file, and I specified that I want to search only files with an extension "*.js,*.jsp,*.java", why even trying to open this file?

And since I'm trying to do a plain-TEXT search on TEXT files, why even bother trying to load / validate a Schema? Just open a Reader on the file and start searching. If you need to parse possible file-encoding from the XML header, there's still no need for Schema validation during a plain-text search. (It only slows matters down, and as seen, has nasty unexpected side effects).

But even with this strange behaviour of schema-validation w

tnleeuw: This error seems to be persistent on startup, by now. I don't know how it got there, or which file is causing the trouble.

tnleeuw: I performed a search through all files in open projects

tnleeuw: find in all files

tnleeuw: Tried to change Maven EAR project's 'run' settings from WebSphere 6.1 to GlassFish 3

tnleeuw: Global search over all files in all open projects

tnleeuw: Trying to do 'Find in Files'...

(This hasn't worked for more than a week already but this is the first time I get an exception, so I guess this error is different than earlier issues with finding text in files)

tnleeuw: Couldn't deploy app to / start Websphere 6.1

tnleeuw: I wanted to do a text search in *.java files; then got this error on a weird websphere-specific file which needs to be in our project.

tnleeuw: This error happened on startup, and I wasn't yet doing anything actually.

org.netbeans.modules.schema2beans.Schema2BeansException: Doc root 'applicationbnd:ApplicationBinding' not found in the DOM graph! Found '' instead.
   at org.netbeans.modules.j2ee.websphere6.dd.beans.WSAppBnd.initFromNode(
   at org.netbeans.modules.j2ee.websphere6.dd.beans.WSAppBnd.<init>(
   at org.netbeans.modules.j2ee.websphere6.dd.beans.WSAppBnd.<init>(
   at org.netbeans.modules.j2ee.websphere6.dd.loaders.appbnd.WSAppBndDataObject.getDD(
   at org.netbeans.modules.j2ee.websphere6.dd.loaders.WSMultiViewDataObject.parseDocument(
   at org.netbeans.modules.j2ee.websphere6.dd.loaders.WSMultiViewDataObject.<init>(
Comment 1 tnleeuw 2011-11-07 10:13:08 UTC
Created attachment 112914 [details]