This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 208431

Summary: Adding Merge Action(Accept Both) for Merge Conflicts Resolver Editor.
Product: utilities Reporter: fortruth <fortruth>
Component: DiffAssignee: Tomas Stupka <tstupka>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kerog
Priority: P3    
Version: 7.1   
Hardware: PC   
OS: Windows 7   
Issue Type: ENHANCEMENT Exception Reporter:

Description fortruth 2012-02-15 03:07:21 UTC
Product Version = NetBeans IDE 7.1 (Build 201112071828)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.6.0_24
Runtime = Java HotSpot(TM) 64-Bit Server VM 19.1-b02


I have an suggestion about the Merge Conflicts Resolver Editor.

That here could have an button for action, merge the conflict lines not only the accept.

I think many people need this action. to keep the conflict line all accepted, not just one side.(local or remote)..

For Example:
==========================
Remote file

74     this is remote added string here..
==========================
Local Working File

74     this is local added string here...


==========================
then the expected result for merge action will be

74     this is remote added string here..
75     this is local added string here...
Comment 1 Ondrej Vrabec 2013-04-17 13:28:15 UTC
*** Bug 228660 has been marked as a duplicate of this bug. ***
Comment 2 markiewb 2013-05-01 19:58:51 UTC
IMHO duplicate of 141198. 

@Original voters of 208431: Please vote again at https://netbeans.org/bugzilla/show_bug.cgi?id=141198

*** This bug has been marked as a duplicate of bug 141198 ***