This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 210392

Summary: Wrong charset in included PHP files
Product: php Reporter: aiken_cz
Component: CodeAssignee: Tomas Mysik <tmysik>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 7.1   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Exception Reporter:

Description aiken_cz 2012-03-29 16:36:02 UTC
Steps to reproduce:
1. Create a PHP project with the UTF-8 charset.
2. Add a folder to "PHP Include Path".
3. Double-click on a file from the "Include path"

Expected behavior: The file is open using the UTF-8 charset.
Current behavior: The file is open using the Windows-1250 charset (the system default).

There is no way how to set the charset for separate files or for the whole Include Path. Thus I think it should use the same charset as the current project.

Product Version = NetBeans IDE 7.1 (Build 201112071828)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.6.0_21
Runtime = Java HotSpot(TM) 64-Bit Server VM 17.0-b17
Comment 1 Tomas Mysik 2012-03-30 09:47:28 UTC
(In reply to comment #0)
> Steps to reproduce:
> 1. Create a PHP project with the UTF-8 charset.
> 2. Add a folder to "PHP Include Path".
> 3. Double-click on a file from the "Include path"
> 
> Expected behavior: The file is open using the UTF-8 charset.
> Current behavior: The file is open using the Windows-1250 charset (the system
> default).

Not true since the Include Path itself does not belong to any project (it cannot because then one could not have 2 projects with 2 different encodings and one Include Path).

> There is no way how to set the charset for separate files or for the whole
> Include Path.

It is; have a look at the issue #204291 - one can find 2 ways how to do that.

> Thus I think it should use the same charset as the current
> project.

It can't, explained above.

Thanks for reporting.

*** This bug has been marked as a duplicate of bug 204291 ***