This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 211133

Summary: [72cat] Diff for XML files using Mercurial does incorrect highlighting
Product: utilities Reporter: crazyjavahacking
Component: DiffAssignee: Tomas Stupka <tstupka>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 7.2   
Hardware: PC   
OS: Windows 7 x64   
Issue Type: ENHANCEMENT Exception Reporter:
Attachments: wrongDiffNetBeans

Description crazyjavahacking 2012-04-13 08:22:10 UTC
Created attachment 118221 [details]
wrongDiffNetBeans

I believe that diff for XML (potentially also other files) using Mercurial is incorrect.

When I change the following part of my maven POM:
"<name>Shared Library packaging</name>" to "<name>Shared Library Packaging</name>"
only one letter should be highlighted but instead the whole word is highlighted.


JDK 7u3, NetBeans Dev 201204100400
Comment 1 Ondrej Vrabec 2012-04-13 10:16:07 UTC
(In reply to comment #0)
> only one letter should be highlighted but instead the whole word is highlighted.
I don't think so, AFAIK it never worked this way

*** This bug has been marked as a duplicate of bug 200734 ***