This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 215217

Summary: AssertionError at
Product: guibuilder Reporter: Exceptions Reporter <exceptions_reporter>
Component: CodeAssignee: issues@guibuilder <issues>
Status: NEW ---    
Severity: normal CC: Chiana, palman
Priority: P3    
Version: 7.2   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter: 190470
Attachments: stacktrace

Description Exceptions Reporter 2012-07-05 20:50:35 UTC
This bug was originally marked as duplicate of bug 130383, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2 Beta (Build 201205031832)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows 7

Comment 1 Exceptions Reporter 2012-07-05 20:50:37 UTC
Created attachment 121775 [details]
Comment 2 Chiana 2012-09-08 07:12:43 UTC
After examining the result I realized the following;

1 An exclamation triangle was put in the upper right corner of the panel.
2 The panel itself were not undone (that was what I tried to undo)
3 the panel was DUPLICATED in the navigator view

point 3 made me check the source too;
1 Only one variable declaration of the panel so that is ok.
2 In the generated code there is two of everything
Comment 3 Tomas Pavek 2012-09-10 12:44:35 UTC
Chiana, in your log file I can see a lot of loading errors (not found class) that might be related to the error. Did this reported exception happen on such a form (that loaded with errors)? Or it was on a good form? Can you reproduce this problem (enclosing and undo), i.e. do you still have the form where it happened? It would be great if you could share a sample form/steps on which we could reproduce the problem, that would help a lot. Thanks.
Comment 4 Chiana 2012-09-10 15:24:48 UTC

Unfortunatley the bad form is gone, this happened in a streak of errors all affecting the same form, you could probable go up/down with the report number to find them all, this particular one occured when trying to undo some changes and occured after, I think it was bug 217867, some previous NPE's and ASSERTS.

The form was initially good, it had one complete panel in it and that one was saved and compiled, but I don't recall if it failed to load, that particular problem occurs too often so it's not easy to remember excatly what was the case in this case.
I solved this one by reverting to a form that was half a day old...
Comment 5 Tomas Pavek 2012-09-10 15:31:45 UTC
If "that particular problem occurs too often" then please next time it happens save the form as it is (the last interrupted operation should be automatically reverted) and try to repeat what you did to reproduce the problem. If you can repeat it, please attach the form to a bug, also describing the steps. Thanks.
Comment 6 Chiana 2012-09-10 19:57:56 UTC
With "that part..." I refered to that the form does not load because embedded beans are not compiled, a build usually fixes that, but perhaps an RFE that NB should check if the component could be compiled and do so before trying to load the form would be an option...