This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 225026

Summary: IllegalArgumentException: len=-519 < 0
Product: editor Reporter: Exceptions Reporter <exceptions_reporter>
Component: -- Other --Assignee: Milutin Kristofic <mkristofic>
Status: RESOLVED FIXED    
Severity: normal CC: developermadan, janario, mkhramov, rodrigorsantos, vriha
Priority: P2    
Version: 7.3   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter: 197688
Attachments: stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace
stacktrace

Description Exceptions Reporter 2013-01-17 13:17:20 UTC
This bug was originally marked as duplicate of bug 207264, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.1-b03, Java(TM) SE Runtime Environment, 1.7.0_05-b05
OS: Windows 7

User Comments:
GUEST: Refactoring code involving traits

GUEST: copy&pasted "extends Form implements \FormBuilder\Service\FormBuilderInterface" to the new class and in the moment the tooltips popped up I wanted to add the uses for this class, ignoring the tooltip.




Stacktrace: 
java.lang.IllegalArgumentException: len=-519 < 0
   at org.netbeans.editor.BaseDocument.handleRemove(BaseDocument.java:898)
   at org.netbeans.editor.BaseDocument$FilterBypassImpl.remove(BaseDocument.java:2417)
   at javax.swing.text.DocumentFilter.remove(DocumentFilter.java:79)
   at org.openide.text.CloneableEditorSupport$DocFilter.remove(CloneableEditorSupport.java:3068)
   at org.netbeans.editor.BaseDocument.remove(BaseDocument.java:884)
   at org.netbeans.modules.csl.editor.completion.GsfCompletionItem$DelegatedItem$1.run(GsfCompletionItem.java:347)
Comment 1 Exceptions Reporter 2013-01-17 13:17:23 UTC
Created attachment 130329 [details]
stacktrace
Comment 2 Milutin Kristofic 2013-01-31 18:37:01 UTC
I cannot reproduce. Please describe some reproducible steps. Till that P4
Comment 3 Vladimir Riha 2013-12-03 16:45:00 UTC
Created attachment 142822 [details]
stacktrace

Happened after focusing item in code completion (inside angularJS expression in HTML file)
Comment 4 Vladimir Riha 2013-12-03 17:02:13 UTC
To reproduce, please try following:

 - download sample project from issue 239090
 - open site root/partials/db.html
 - on line 3, place cursor inside {{}} expression and invoke cc
 - type d to narrow it
 - press Up arrow so selected item in cc is DBFct
 - press Enter to complete it

=> IAE
Comment 5 janario 2013-12-05 19:36:31 UTC
Created attachment 142884 [details]
stacktrace

Editing xhtml
Comment 6 Exceptions Reporter 2013-12-05 19:36:37 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=197688
Comment 7 rodrigorsantos 2013-12-10 22:54:44 UTC
Created attachment 143035 [details]
stacktrace

<Please provide a description of the problem or the steps to reproduce>
Comment 8 Maksim Khramov 2013-12-11 10:12:44 UTC
Created attachment 143049 [details]
stacktrace

Edit JSP code
Comment 9 Maksim Khramov 2013-12-11 10:24:28 UTC
Product Version: NetBeans IDE Dev (Build 201312110002)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08

Steps to reproduce:
Opened jsp page in editor
Editing code:
                <rich:column>
                    <a4j:commandLink action="#{PeopleManager.}"
                </rich:column>
Code complete invoked after PeopleManager. 
Inserted function name from bean:

    public String obsoletePerson() {
        return "./faces/PeopleManager.jsp";
    }

Exception is thrown.
And I see that some surrounding jsf code becomes broken.
Comment 10 Vladimir Riha 2013-12-13 09:06:53 UTC
Created attachment 143132 [details]
stacktrace

confirmed suggested item in code completion
Comment 11 janario 2013-12-13 20:00:52 UTC
Created attachment 143172 [details]
stacktrace

editing xhtml
Comment 12 Miloslav Metelka 2014-01-06 09:52:39 UTC
Cannot reproduce but I've added an extra checking that should eliminate the problem.
http://hg.netbeans.org/jet-main/rev/e37a6f66a83b
Comment 13 Quality Engineering 2014-01-07 02:49:14 UTC
Integrated into 'main-silver', will be available in build *201401070002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e37a6f66a83b
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #225026 - IllegalArgumentException: len=-519 < 0.