This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 229037

Summary: JPA hint "The project does not contain a persistence unit" should not be a warning
Product: javaee Reporter: athompson <athompson>
Component: PersistenceAssignee: Sergey Petrov <sj-nb>
Status: RESOLVED DUPLICATE    
Severity: normal CC: dkonecny
Priority: P3    
Version: 7.4   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:

Description athompson 2013-04-25 23:50:36 UTC
It's fairly common to define a JPA data model in a completely separate project, and have your EJBs/application depend on that model project. That way, you can have multiple versions of the same model which map to different database schemata, and your EJBs can target a particular schema simply by depending on the appropriate model project.

In this case, the model project does not and should not contain a persistence unit, since it's defined in the EJB. Please lower the warning level of the "The project does not contain a persistence unit" hint to "warning on current line", or make this configurable.
Comment 1 Sergey Petrov 2013-04-29 08:12:53 UTC
I hope it will be configurable, i.e. will be same way as almost all others hints (disable/enable/level). Will try to implement in next release.

*** This bug has been marked as a duplicate of bug 215179 ***