This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 232002

Summary: Property might not be offered if there are some preceding chars
Product: web Reporter: Vladimir Riha <vriha>
Component: AngularJSAssignee: Roman Svitanic <rsvitanic>
Status: RESOLVED DUPLICATE    
Severity: normal CC: mfukala, ppisl
Priority: P3    
Version: 7.4   
Hardware: PC   
OS: Linux   
Issue Type: DEFECT Exception Reporter:
Attachments: screenshot
IDE log

Description Vladimir Riha 2013-06-28 15:05:51 UTC
Created attachment 136469 [details]
screenshot

Please try:

<div class="container-fluid">
    <div class="row-fluid">
            Search: <input ng-bind="attempt.val">
        <div class="span10">
            <h1>{{attempt.nic}}</h1>
            {{a
            
            <ul class="phones">
                <li ng-repeat="phone in phones | orderBy:orderProp" class="thumbnail">
                </li>
            </ul>

        </div>
    </div>
</div>


- place cursor after {{a and press Space and backspace
- now invoke cc 

=> attempt is not offered, if I delete a and invoke cc, then it is.



Product Version: NetBeans IDE Dev (Build 201306272300)
Updates: Updates available
Java: 1.7.0_25; Java HotSpot(TM) Client VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b15
System: Linux version 3.2.0-45-generic-pae running on i386; UTF-8; en_US (nb)
Comment 1 Vladimir Riha 2013-06-28 15:06:17 UTC
Created attachment 136470 [details]
IDE log
Comment 2 Petr Pisl 2013-08-20 20:58:33 UTC
This should be already fixed. I can not reproduce it in dev build now.
Comment 3 Vladimir Riha 2013-08-22 07:01:23 UTC
I'm sorry, still reproducible. It works OK if there is also closing }} for the expression. If it's missing, only 4 items in cc are offered and "attempt" is not one of them

Product Version: NetBeans IDE Dev (Build 201308212300)
Updates: Updates available
Java: 1.7.0_40; Java HotSpot(TM) Client VM 24.0-b55
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b39
System: Linux version 3.2.0-48-generic-pae running on i386; UTF-8; en_US (nb)
Comment 4 Roman Svitanic 2014-11-21 15:38:28 UTC
I can't reproduce the issue anymore.

Product Version: NetBeans IDE Dev (Build 20141121-ab60b41e7116)
Java: 1.7.0_67; Java HotSpot(TM) 64-Bit Server VM 24.65-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_67-b01
System: Mac OS X version 10.10.1 running on x86_64; UTF-8; en_US (nb)
Comment 5 Vladimir Riha 2014-11-23 16:39:45 UTC
I'm sorry but still does not work for me, if the closing }} is missing, I don't get "attempt" in cc list


Product Version: NetBeans IDE Dev (Build 201411230001)
Java: 1.7.0_72; Java HotSpot(TM) Client VM 24.72-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_72-b14
System: Linux version 3.13.0-35-generic running on i386; UTF-8; en_US (nb)
Comment 6 Roman Svitanic 2014-11-24 08:08:24 UTC

*** This bug has been marked as a duplicate of bug 237946 ***