This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 233086

Summary: [dark] tooltips of disabled toobar items have no border
Product: platform Reporter: markiewb
Component: JDK ProblemsAssignee: Antonin Nebuzelsky <anebuzelsky>
Status: RESOLVED WONTFIX    
Severity: normal Keywords: NO74
Priority: P4    
Version: 7.4   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Exception Reporter:
Attachments: Shows the issue

Description markiewb 2013-07-19 18:02:35 UTC
Created attachment 137469 [details]
Shows the issue

ACTUAL:
Hover above a toolbar item, which is enabled -> tooltip with border is shown
Hover above a toolbar item, which is disabled -> tooltip without border is shown
- see screenshot

EXPECTED:
Hover above a toolbar item, which is enabled -> tooltip with border is shown
Hover above a toolbar item, which is disabled -> tooltip with border is shown

Dark Nimbus
Comment 1 Stanislav Aubrecht 2013-07-29 10:42:38 UTC
core-main 9a7804ede0c9
Comment 2 Quality Engineering 2013-07-31 02:23:17 UTC
Integrated into 'main-silver', will be available in build *201307302300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/9a7804ede0c9
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #233086 - lighter border of disabled tooltips
Comment 3 markiewb 2013-08-01 14:44:41 UTC
Sorry for reopening this issue. The issue is still valid using Dark Nimbus (not Dark Metal - see screenshot). 
Tested with 201307312300
Comment 4 Stanislav Aubrecht 2013-08-02 10:26:58 UTC
(In reply to comment #3)
> Sorry for reopening this issue. The issue is still valid using Dark Nimbus (not
> Dark Metal - see screenshot). 
> Tested with 201307312300

I see, it's actually a bug in Nimbus l&f - there is no Tooltip painter for 'disabled' state.
Comment 5 Marian Mirilovic 2013-08-23 13:53:13 UTC
Dark themes were moved to the NetBeans Update Center for NB 7.4
Comment 6 Antonin Nebuzelsky 2013-12-27 12:19:40 UTC
https://bugs.openjdk.java.net/browse/JDK-6789983