This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 233142

Summary: [dark] [nimbus] Cursor/selection not visible in dark themes
Product: platform Reporter: sreimers <sreimers>
Component: Window SystemAssignee: Stanislav Aubrecht <saubrecht>
Status: RESOLVED FIXED    
Severity: normal CC: everflux, lkishalmi, ssazonov
Priority: P3 Keywords: L&F, PATCH_AVAILABLE, SIMPLEFIX
Version: 7.4   
Hardware: PC   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 239990    
Attachments: screenshot dark nimbus
Dark Nimbus on Windows 7 jdk8 b99 norway today
Compares Dark Nimbus with Dark Metal on Win7
screenshot
Proposed patch.

Description sreimers 2013-07-22 06:45:26 UTC
If I try to search for something in an editor window, I can't see the cursor in the search box.

Same goes for the selection.
Comment 1 Milutin Kristofic 2013-07-22 12:17:47 UTC
There was already fix in Bug #223861. What is your current version/build? What is Look and feel? What is your font&colors profile? Can you please attach log and screenshot? Thank you
Comment 2 sreimers 2013-07-24 05:56:54 UTC
This is with latest NetBeans 7.4 (dev build 201307152300), will retest with latest again.

The problem occurs with Dark Nimbus & Norway Today or City Lights running on Windows 7
Comment 3 Milutin Kristofic 2013-07-24 14:38:31 UTC
Created attachment 137705 [details]
screenshot dark nimbus

You can see on my screenshot that selection works fine in dark nimbus (norway today)
Comment 4 sreimers 2013-07-24 15:33:13 UTC
Created attachment 137719 [details]
Dark Nimbus on Windows 7 jdk8 b99 norway today

No highlighting visible
Comment 5 sreimers 2013-07-24 15:34:28 UTC
The Screenshot was taken with build 201307222300 on JDK8 b99
Comment 6 Milutin Kristofic 2013-07-24 15:39:24 UTC
Oh, you are using JDK8. That can be a problem.
Comment 7 markiewb 2013-07-29 22:28:25 UTC
According to my observation it only happens using Dark Nimbus (Dark Metal is OK).

Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b16
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 8 markiewb 2013-07-29 22:32:55 UTC
Created attachment 137971 [details]
Compares Dark Nimbus with Dark Metal on Win7
Comment 9 markiewb 2013-07-29 22:35:26 UTC
(In reply to comment #3)
> Created attachment 137705 [details]
> screenshot dark nimbus
> 
> You can see on my screenshot that selection works fine in dark nimbus (norway
> today)

Veto, Milutin! The screenshot shows the (working) Dark Metal LAF - not Dark Nimbus!
Comment 10 Milutin Kristofic 2013-08-07 12:41:50 UTC
*** Bug 234078 has been marked as a duplicate of this bug. ***
Comment 11 Ondrej Vrabec 2013-08-08 06:42:36 UTC
mito, this is not specific to JDK8, i use JDK7 and the caret in the search bar is almost invisible (black on dark blue background). Why don't you use the same color as in editor (yellow)? See the attached screenshot.
Comment 12 Ondrej Vrabec 2013-08-08 06:43:05 UTC
Created attachment 138435 [details]
screenshot
Comment 13 Milutin Kristofic 2013-08-08 09:51:00 UTC
Ondra, look on Bug #223861, I cannot use editor caret, since someone can have dark font&colors profile and light laf.
Comment 14 Milutin Kristofic 2013-08-08 11:48:23 UTC
I am working on this.
Comment 15 Marian Mirilovic 2013-08-23 13:53:15 UTC
Dark themes were moved to the NetBeans Update Center for NB 7.4
Comment 16 Milutin Kristofic 2014-01-14 16:05:00 UTC
*** Bug 239990 has been marked as a duplicate of this bug. ***
Comment 17 lkishalmi 2014-10-24 19:52:56 UTC
Well, it seems a few color settings are missing from the DarkNimbusTheme.
I have a trivial patch for that.
Comment 18 lkishalmi 2014-10-24 20:50:52 UTC
Created attachment 150109 [details]
Proposed patch.

This patch should fix the selection background on DarkNimbus and it is required to fix #239990 with DarkNimbus.
Comment 19 Stanislav Aubrecht 2014-10-31 11:07:09 UTC
core-main 5ffec85c29bc

Thanks for the patch!
Comment 20 Quality Engineering 2014-11-01 04:46:46 UTC
Integrated into 'main-silver', will be available in build *201411010002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/5ffec85c29bc
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #233142 - Cursor/selection not visible in dark Nimbus theme