Bug 235551

Summary: Use Ctrl+Shift+I to resolve namespace declarations
Product: javaee Reporter: Vladimir Riha <vriha>
Component: JSF EditorAssignee: Martin Fousek <marfous>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 7.4   
Hardware: PC   
OS: Linux   
Issue Type: ENHANCEMENT Exception Reporter:

Description Vladimir Riha 2013-09-05 11:54:55 UTC
It could be handy to use the Ctrl+Shift+I shortcut for resolving (add missing, remove unused) namespace declarations in XHTML facelet page. Semantically it is similar action to e.g. adding imports in Java or uses in PHP.
Comment 1 Vladimir Riha 2013-09-05 11:55:33 UTC
But it would probably require also dialog where user can select proper namespaces if there are multiple choices :)
Comment 2 Martin Fousek 2013-09-09 07:01:03 UTC
Thanks Vlado for the report. It's definitelly great idea and I think that users would appreciate that. Actually I found similar issue by creation of plans for NB80, so I'm marking this issue as a duplicate. But I believe that we will be implement this into next version.

*** This bug has been marked as a duplicate of bug 205232 ***