This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 239474

Summary: New File - Browser button doesn't work
Product: projects Reporter: Spindeman
Component: Generic InfrastructureAssignee: Milos Kleint <mkleint>
Status: REOPENED ---    
Severity: normal    
Priority: P3    
Version: 7.4   
Hardware: Macintosh (x86)   
OS: Mac OS X   
Issue Type: DEFECT Exception Reporter:

Description Spindeman 2013-12-13 14:36:05 UTC
Hello,
When I choose File - New File and then I choose the type of file I want, no problem.  Then, when I click on Browse to change the destination where the file should be save, nothing... The Browse button doesn't work.
Comment 1 Jaroslav Havlin 2013-12-13 14:57:03 UTC
I cannot reproduce this bug.
It may be a general problem in Project support, or it can be specific to a single file type.

Spindeman, what file type did you choose? Did you try other file types?

Reassigning to projects/Generic Infrastructure.
Milos, please evaluate, thanks.
Comment 2 Spindeman 2013-12-13 16:38:26 UTC
I was creating a html file.
I also tried with another file type, same problem :(
I'll try reassigning and get back here.
The default saving files settings c:/users/Me
Comment 3 Martin Kozeny 2013-12-16 14:23:49 UTC
Works also fine for me on:

Product Version: NetBeans IDE Dev (Build 201312100002)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Linux version 3.5.0-37-generic running on amd64; UTF-8; en_US (nb


Please what environment do you use? Thank you.
Comment 4 Milos Kleint 2013-12-17 08:18:34 UTC
Spindeman: what is your jdk?
have you changed the look and feel in Tools/Options dialog? (Look and feel tab)
have you checked the "maximize use of native look and feel" checkbox?
also please attach your messages log file - http://wiki.netbeans.org/FaqLogMessagesFile
Comment 5 Milos Kleint 2014-01-21 14:11:34 UTC
please provide additional information and reopen, we cannot evaluate with the current problem description. thanks.
Comment 6 bace135 2014-04-01 19:30:14 UTC
I just installed netbeans, first thing I tried was to create a new html file, and had this same issue.

Product Version: NetBeans IDE 8.0 (Build 201403101706)
Java: 1.8.0; Java HotSpot(TM) 64-Bit Server VM 25.0-b70
Runtime: Java(TM) SE Runtime Environment 1.8.0-b132
System: Windows 8 version 6.2 running on amd64; Cp1252; en_US (nb)
Comment 7 bace135 2014-04-01 19:35:14 UTC
Just noticed that if I have created a project (in my case php project), that the browse button does work when creating a new html file.

The issue I had before was before any projects were created.
Comment 8 ckoehler 2014-09-28 07:29:59 UTC
Same issue here. When I create a new File, WITHOUT a project, the browse-button does not open a file-dialog.

Product Version: NetBeans IDE 8.0.1 (Build 201408251540)
Java: 1.8.0_20; Java HotSpot(TM) 64-Bit Server VM 25.20-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0_20-b26
System: Windows 8 version 6.2 running on amd64; UTF-8; de_DE (nb)
Comment 9 JHuarte 2015-02-18 18:39:28 UTC
Same issue now on 2015. When I create a new HTML File, WITHOUT a project, the browse-button does not open a file-dialog.

I know there is nothing new here, but I add this comment because the previous comments are old enough and the "defect" keeps working.

Product Version: NetBeans IDE 8.0.2 (Build 201411181905)
Java: 1.8.0; Java HotSpot(TM) 64-Bit Server VM 25.0-b70
Runtime: Java(TM) SE Runtime Environment 1.8.0-b132
System: Linux version 3.2.0-76-generic running on amd64; UTF-8; es_ES (nb)
User directory: /home/user/.netbeans/8.0
Cache directory: /home/user/.cache/netbeans/8.0
Comment 10 Martin Balin 2016-07-07 08:38:07 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss
Comment 11 feldbot 2017-02-24 03:59:20 UTC
Hi, I have the same problem described in this case. I have NB 8.2, Mac OSX 10.10.2. When I click new file/other/html file, the browse button does nothing. I have to manually paste in the file path. Glad to help troubleshoot to resolve. Thanks!
Comment 12 theflyingsofa 2017-02-25 05:04:57 UTC
I'm having the same issue. Installed the IDE today but some buttons do not work.
Comment 13 PifLyon 2017-06-23 09:54:41 UTC
Hi,
Just installed Netbeans today for the first time.

I can not choose the path for my new file as the browse button doesn't do anything.

- Fresh install on windows home 1607.
- File > new file...
- Browse = nothing.

Discovered that it works if doing "new project" first. As a new user I did not understood this.

Maybe a warning "You must create a project first" would be usefull for new users !

Regards.
C├ędric.