This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 242553

Summary: NullPointerException at org.netbeans.modules.php.project.connections.sftp.SftpClient.setProxy
Product: php Reporter: mmolda
Component: ProjectAssignee: Tomas Mysik <tmysik>
Status: VERIFIED FIXED    
Severity: normal CC: CoffeeNerd, kvv157, mmirilovic, mmolda, ovrabec, vriha
Priority: P2 Keywords: 8.0_HR_FIX
Version: 8.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter: 205594
Attachments: stacktrace

Description mmolda 2014-03-04 16:27:52 UTC
Build: NetBeans IDE Dev (Build 201403040001)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b69, Java(TM) SE Runtime Environment, 1.8.0-b131
OS: Windows 7

User Comments:
CoffeeNerd: This just started happening after I installed the current daily build - now none of my installations (production 7.4 patch 1, 20131108 build nor this build are able to upload files to my remote server via sFTP.

GUEST: I tried to make a remote php project.
Used SFTP connection mode and hit test connection button

mmolda: Configuring new SFTP connection. Filled in Host name, username, password and clicked on Test Connection - exception thrown.

GUEST: upload not possible <Please provide a description of the problem or the steps to reproduce>




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.php.project.connections.sftp.SftpClient.setProxy(SftpClient.java:270)
   at org.netbeans.modules.php.project.connections.sftp.SftpClient.createSftpSession(SftpClient.java:207)
   at org.netbeans.modules.php.project.connections.sftp.SftpClient.init(SftpClient.java:156)
   at org.netbeans.modules.php.project.connections.sftp.SftpClient.connect(SftpClient.java:285)
   at org.netbeans.modules.php.project.connections.RemoteClient.connect(RemoteClient.java:193)
   at org.netbeans.modules.php.project.connections.ui.RemoteConnectionsPanel.testConnection(RemoteConnectionsPanel.java:252)
Comment 1 mmolda 2014-03-04 16:27:54 UTC
Created attachment 145751 [details]
stacktrace
Comment 2 Tomas Mysik 2014-03-05 07:23:45 UTC
Unfortunately, this happens for SFTP if proxy is used. Definitely a patch candidate...

Should be fixed now, please verify (proxy, no proxy, ssh-agent, no ssh-agent). 

Thanks!

http://hg.netbeans.org/web-main/rev/a81945598267
Comment 3 Tomas Mysik 2014-03-05 07:48:44 UTC
Since the fix should be safe (reviewed by Ondra), transplanting to release repo to branch release80.

Thanks!

http://hg.netbeans.org/releases/rev/10e4373400d8
Comment 4 Tomas Mysik 2014-03-05 07:50:06 UTC
Láďo/Milane, verify please this issue in latest biuld of NB 8.0. Thanks a lot.
Comment 5 Tomas Mysik 2014-03-05 07:50:42 UTC
Sorry, I have removed the keyword.
Comment 6 Quality Engineering 2014-03-06 01:11:58 UTC
Integrated into 'releases/release80', will be available in build *201403052200* or newer. Wait for official and publicly available build.

Changeset: http://hg.netbeans.org/releases/rev/10e4373400d8
User: Tomas Mysik <tmysik@netbeans.org>
Log: #242553 - NullPointerException at org.netbeans.modules.php.project.connections.sftp.SftpClient.setProxy
(transplanted from a81945598267160779c52b5fc1a4c381af6d89a0)
Comment 7 mmolda 2014-03-06 09:15:21 UTC
Works great. I also tried upload/download/synchronize.
Thanks.

Product Version: NetBeans IDE 8.0 (Build 201403052200)
Java: 1.8.0; Java HotSpot(TM) 64-Bit Server VM 25.0-b69
Runtime: Java(TM) SE Runtime Environment 1.8.0-b131
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
Comment 8 Quality Engineering 2014-03-07 02:40:14 UTC
Integrated into 'main-silver', will be available in build *201403070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/a81945598267
User: Tomas Mysik <tmysik@netbeans.org>
Log: #242553 - NullPointerException at org.netbeans.modules.php.project.connections.sftp.SftpClient.setProxy
Comment 9 Marian Mirilovic 2014-05-26 07:44:09 UTC
*** Bug 244061 has been marked as a duplicate of this bug. ***