This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 246934

Summary: NullPointerException at com.sun.tools.javac.jvm.Code.emitop0
Product: java Reporter: Alexander Simon <alexvsimon>
Component: CompilerAssignee: Dusan Balek <dbalek>
Status: RESOLVED FIXED    
Severity: normal CC: alexvsimon, thilina01
Priority: P2    
Version: 8.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter: 211642
Attachments: stacktrace
stacktrace

Description Alexander Simon 2014-09-09 07:08:21 UTC
This bug was originally marked as duplicate of bug 178299, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 8.0.1 (Build 20140909-5534af5d348a)
VM: Java HotSpot(TM) Client VM, 24.65-b04, Java(TM) SE Runtime Environment, 1.7.0_67-b01
OS: SunOS

User Comments:
alexvsimon: open project

alexvsimon: open file




Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.jvm.Code.emitop0(Code.java:566)
   at com.sun.tools.javac.jvm.Items$SelfItem.load(Items.java:367)
   at com.sun.tools.javac.jvm.Gen.genArgs(Gen.java:969)
   at com.sun.tools.javac.jvm.Gen.visitNewClass(Gen.java:1991)
   at com.sun.tools.javac.tree.JCTree$JCNewClass.accept(JCTree.java:1522)
   at com.sun.tools.javac.jvm.Gen.genExpr(Gen.java:950)
Comment 1 Alexander Simon 2014-09-09 07:08:23 UTC
Created attachment 149076 [details]
stacktrace
Comment 2 Alexander Simon 2014-09-09 07:14:12 UTC
P2 because original problem (bug #178299) was not resolved
Comment 3 Alexander Simon 2015-04-22 09:23:01 UTC
Created attachment 153294 [details]
stacktrace

navigate in source code
Comment 4 Dusan Balek 2015-04-23 09:57:39 UTC
Enhanced logging.

http://hg.netbeans.org/main/nb-javac/rev/927d8055cbea
Comment 6 Quality Engineering 2015-07-24 01:18:35 UTC
Integrated into 'main-silver', will be available in build *201507240001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/5717bab8dff2
User: Dusan Balek <dbalek@netbeans.org>
Log: Issues #246934 and #252661 fixed.
Comment 7 Dusan Balek 2016-06-01 14:38:29 UTC
*** Bug 254191 has been marked as a duplicate of this bug. ***