This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 247548

Summary: Norway today theme - cyrillic characters are broken, when under comment
Product: editor Reporter: PavelPolyakov
Component: Painting & PrintingAssignee: Miloslav Metelka <mmetelka>
Status: REOPENED ---    
Severity: normal    
Priority: P3    
Version: 8.2   
Hardware: Macintosh (x86)   
OS: Mac OS X   
Issue Type: DEFECT Exception Reporter:
Attachments: correct and incorrect display of the cyrillic characters

Description PavelPolyakov 2014-09-29 10:06:50 UTC
Created attachment 149585 [details]
correct and incorrect display of the cyrillic characters

I've attached two pictures, on the first - the simple string with the cyrillic characters, it's displayed well.
As soon as I would add the comment characters in front of it - it would be broken.

The same thing would take place if I wrap it with the /* and */ characters.
When I'm trying to type inside the comment block - it prints some strange characters there, as well.

With the default NetBeans theme it works well.
Comment 1 PavelPolyakov 2014-09-29 13:53:24 UTC
Somehow I'm not able to reproduce it before, after I've restarted the NetBeans 8.0.1.
Comment 2 PavelPolyakov 2014-09-29 16:12:04 UTC
The problem is still there, currently the text in the comments works well, but outside of them - it's broken.

Please, investigate.
Comment 3 ddanecki 2018-12-28 10:03:21 UTC
I've got the same problem with 8.2 with Norway today theme.

Cyrillic letters when commented are being displayed correctly. When uncommented they're messed up.

After changing the theme to a different one, restarting Netbeans, then changing it back to Norway today, it started to work the other way around. When commented, it's messed up, when not, it's ok.