This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 248884

Summary: CC doesn't work on the second use trait statement
Product: php Reporter: pchela.ilya
Component: EditorAssignee: Tomas Mysik <tmysik>
Status: RESOLVED FIXED    
Severity: normal CC: junichi11, tmysik, xprt64
Priority: P3 Keywords: 8.0_HR_FIX
Version: 8.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Attachments: Журнал среды IDE
patch

Description pchela.ilya 2014-11-25 11:44:07 UTC
Product Version = NetBeans IDE 8.0 (Build 201408251540)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_25
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.25-b01

if you have more then one trait inside class, second traid don't use autocomplete
for example
class BinList{
	use MockingTrait;
	use TestCrudHelpTrait;
}

trait TestCrudHelpTrait not showed in autocomplete.
Comment 1 pchela.ilya 2014-11-25 11:44:19 UTC
Created attachment 150686 [details]
Журнал среды IDE
Comment 2 junichi11 2016-03-14 04:55:21 UTC
*** Bug 258213 has been marked as a duplicate of this bug. ***
Comment 3 junichi11 2016-03-16 04:30:58 UTC
Created attachment 158883 [details]
patch
Comment 4 junichi11 2016-03-16 04:33:53 UTC
I've created a patch.

Tomas, Could you please review it when you can make time?

Thanks!
Comment 5 Tomas Mysik 2016-03-16 06:30:23 UTC
I will apply the patch, thanks a lot for it, Junichi!
Comment 6 Tomas Mysik 2016-03-16 07:15:22 UTC
Patch applied, thanks a lot Junichi!

http://hg.netbeans.org/web-main/rev/5ca5ba985d7e
Comment 7 Quality Engineering 2016-03-17 02:40:31 UTC
Integrated into 'main-silver', will be available in build *201603170001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/5ca5ba985d7e
User: Tomas Mysik <tmysik@netbeans.org>
Log: #248884 - CC doesn't work on the second use trait statement

Patch contributed by junichi11@netbeans.org.