This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 248981

Summary: Scrambled characters in output on Windows in NPM output
Product: javascript Reporter: Vladimir Riha <vriha>
Component: ToolsAssignee: Tomas Mysik <tmysik>
Status: VERIFIED FIXED    
Severity: normal CC: tmysik
Priority: P2    
Version: 8.1   
Hardware: PC   
OS: Windows 7   
Issue Type: DEFECT Exception Reporter:
Attachments: IDE log

Description Vladimir Riha 2014-11-28 13:13:04 UTC
Created attachment 150767 [details]
IDE log

Please try following in Windows:
 - create a new sample project Messages
 - open Resolve project problems dialog
 - select "missing npm modules" and press Resolve

=> check output in output window, it contains things like


grunt@0.4.5 node_modules\grunt
├── dateformat@1.0.2-1.2.3
├── which@1.0.7
├── eventemitter2@0.4.14
├── getobject@0.1.0
├── colors@0.6.2
├── rimraf@2.2.8



There used to be similar issue 245545 so reporting as P2 since it is regression. Thank you
Comment 1 Vladimir Riha 2014-11-28 13:13:15 UTC
Product Version: NetBeans IDE Dev (Build web-main-1608-on-20141128)
Java: 1.8.0_11; Java HotSpot(TM) 64-Bit Server VM 25.11-b03
Runtime: Java(TM) SE Runtime Environment 1.8.0_11-b12
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 2 Tomas Mysik 2014-11-28 13:48:36 UTC
Taking over.
Comment 3 Tomas Mysik 2014-12-01 11:04:40 UTC
Should be fixed now, including Bower. Thanks.

http://hg.netbeans.org/web-main/rev/bc2480948a91
Comment 4 Quality Engineering 2014-12-02 04:04:14 UTC
Integrated into 'main-silver', will be available in build *201412020001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/bc2480948a91
User: Tomas Mysik <tmysik@netbeans.org>
Log: #248981 - Scrambled characters in output on Windows in NPM output
Comment 5 Vladimir Riha 2014-12-11 20:06:21 UTC
Verified, thank you


Product Version: NetBeans IDE Dev (Build 201412111033)
Java: 1.8.0_11; Java HotSpot(TM) 64-Bit Server VM 25.11-b03
Runtime: Java(TM) SE Runtime Environment 1.8.0_11-b12
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)