This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 251566

Summary: Upgrade JAXB shipped with NetBeans
Product: xml Reporter: qwertyscar1
Component: JAXBAssignee: Svata Dedic <sdedic>
Status: NEW ---    
Severity: normal CC: anebuzelsky, crispaiola, gdm-nb, mbalin, monsieurp
Priority: P2 Keywords: 8.1_WAIVER_APPROVED
Version: 8.0.2   
Hardware: PC   
OS: Windows 8   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 233591    
Attachments: the schema I'm trying to import with jaxb

Description qwertyscar1 2015-04-01 15:28:57 UTC
Created attachment 152980 [details]
the schema I'm trying to import with jaxb

I tried to add a JAXB binding to some projects, with JDK7 code level I get this error:
ant -f "C:\\Users\\Marco Scarpa\\Documents\\NetBeansProjects\\JavaFXApplication1" jaxb-code-generation
xjc-typedef-target:
jaxb-code-generation:
Created dir: C:\Users\Marco Scarpa\Documents\NetBeansProjects\JavaFXApplication1\build\generated\jaxbCache\DaSap
Compiling file:/C:/Users/Marco%20Scarpa/Documents/NetBeansProjects/JavaFXApplication1/xml-resources/jaxb/DaSap/listino_da_SAP.xsd
Writing output to C:\Users\Marco Scarpa\Documents\NetBeansProjects\JavaFXApplication1\build\generated\jaxbCache\DaSap
C:\Users\Marco Scarpa\Documents\NetBeansProjects\JavaFXApplication1\nbproject\xml_binding_build.xml:15: 
java.lang.IllegalArgumentException: Illegal pattern character 'g'
	at java.text.SimpleDateFormat.compile(SimpleDateFormat.java:826)
	at java.text.SimpleDateFormat.initialize(SimpleDateFormat.java:634)
	at java.text.SimpleDateFormat.<init>(SimpleDateFormat.java:605)
	at com.sun.tools.xjc.Options.getPrologComment(Options.java:924)
	at com.sun.tools.xjc.Options.createCodeWriter(Options.java:909)
	at com.sun.tools.xjc.Options.createCodeWriter(Options.java:899)
	at com.sun.tools.xjc.XJC2Task._doXJC(XJC2Task.java:523)
	at com.sun.tools.xjc.XJC2Task.doXJC(XJC2Task.java:454)
	at com.sun.tools.xjc.XJC2Task.execute(XJC2Task.java:379)
	at com.sun.istack.tools.ProtectedTask.execute(ProtectedTask.java:103)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)
	at sun.reflect.GeneratedMethodAccessor152.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:435)
	at org.apache.tools.ant.Target.performTasks(Target.java:456)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1393)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1364)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1248)
	at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:286)
	at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:555)
	at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:153)
BUILD FAILED (total time: 1 second)


Instead when I try with a JDK8 level marked project I get :

ant -f "C:\\Users\\Marco Scarpa\\Documents\\NetBeansProjects\\PdfFromSelector" jaxb-code-generation
Target "jaxb-code-generation" does not exist in the project "PdfFromSelector". 
BUILD FAILED (total time: 0 seconds)

I don't know if there are schema issues, but I think that for JDK8 level source is an issue that the build target is not included in target generation, I attach the schema
Comment 1 Svata Dedic 2015-04-28 14:25:17 UTC
Please include your IDE/Java/Environment settings. If unsure, copy contents of the Help | About product info box.
What's your langugage setting ?
Comment 2 Svata Dedic 2015-04-28 14:32:20 UTC
*** Bug 216575 has been marked as a duplicate of this bug. ***
Comment 3 Svata Dedic 2015-04-28 14:42:10 UTC
The shipped JAXB is rather ancient (2.2.5-x impl) while 2.2.11 RI is alraedy released/available from jaxb.java.net

JAXB shipped with JDK8 is 2.2.8, which already contains this bugfix: _it bundle contains an invalid format string (see https://java.net/jira/secure/attachment/51015/italian-patch.patch).

As a quick help, set your language to en ("-J-Duser.language=en" to netbeans_default_options in netbeans.conf)
Comment 4 monsieurp 2015-05-22 13:07:22 UTC
Hi there.

Gentoo developer here. We're hitting the same problem on Gentoo Linux. Since we're a source-based Linux distribution, our package manager is able to compile NetBeans 8.0.2 from sources. Our users have reported a similiar problem when compiling netbeans-websvccommon.

Here's the full stack trace:

https://435022.bugs.gentoo.org/attachment.cgi?id=403730

and the bug report:

https://bugs.gentoo.org/show_bug.cgi?id=435022

Any idea on how to solve this annoying bug?

Thanks for your help! :)
Comment 5 monsieurp 2015-06-14 22:58:07 UTC
ping!

Could someone look into this issue? or at least let me (us) know it isn't falling into oblivion? 

Cheers
Comment 6 Svata Dedic 2015-06-15 05:54:24 UTC
Legal administrativia should be already under way.

In the meantime, if you can apply source patches to upstream sources, use https://java.net/jira/secure/attachment/51015/italian-patch.patch from comment #3
Comment 7 monsieurp 2015-06-28 09:50:10 UTC
Hi Svata

I didn't get a chance to thank you. Your pointer fixed the issue for us in Gentoo. We've marked the bug as FIXED. 

https://bugs.gentoo.org/show_bug.cgi?id=435022

Thanks a lot!

Cheers
Comment 8 Svata Dedic 2015-09-04 08:12:08 UTC
I was said that legal approvals for including an updated JAXB are still not processed. I originally planned to have some testing period with updated libraries to verify that especially JEE modules work fine with the new implementation. This [so far only] defect known to be fixed by the new release has a known work-around and I do not want to affect release by library changes made late in the cycle - I want to ask for a waiver and postpone the upgrade to the next version.
Comment 9 Jiri Kovalsky 2015-09-07 10:47:36 UTC
Bug waiver for 8.1 approved.
Comment 10 monsieurp 2015-09-07 11:04:55 UTC
I'm catching up on this bug just now after many months. Apparently, this issue is still actual for us in Gentoo and the bug has been reopened since. Thank you for the waiver and for providing JAXB sources.