This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 25169

Summary: Default editor size after creating a new project
Product: platform Reporter: Jan Lahoda <jlahoda>
Component: Window SystemAssignee: mslama <mslama>
Status: CLOSED DUPLICATE    
Severity: blocker CC: mmirilovic, pzavadsky
Priority: P3    
Version: 3.x   
Hardware: Sun   
OS: SunOS   
Issue Type: DEFECT Exception Reporter:
Attachments: Editor opened after new project created.

Description Jan Lahoda 2002-06-26 09:37:20 UTC
200206260100, JDK1.4fcs, MDI.
1. Start an IDE from brand new userdir.
2. Close welcome screen, open an editor (probably
not necessary).
3. Create a new project (Project/Project
Manager/New...)
4. Mount a filesystem (I mounted sampledir).
5. Open a Java editor (in my case: ClockFrame
opened using Edit).
6. The editor is too small (shouldn't it be
maximized?). See screenshot.
Comment 1 Jan Lahoda 2002-06-26 09:38:44 UTC
Created attachment 6427 [details]
Editor opened after new project created.
Comment 2 Marian Mirilovic 2002-06-26 10:23:03 UTC
Well, I try these steps and found some mysterious window system
behaviour :
- you must let opened Source Editor on the Default project, otherwise
(closed Source Editor in Default Project, create new project, open
source editor) Source Editor is in new project opened maximized

So, steps to reproduce:
- run IDE
- close welcome
- open some file
- create new project
- open some file 
-> source editor is restored
Comment 3 mslama 2002-07-01 17:18:11 UTC

*** This issue has been marked as a duplicate of 25268 ***
Comment 4 Quality Engineering 2003-07-01 15:53:22 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified.

Comment 5 Quality Engineering 2003-07-01 16:31:13 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.