This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 252728

Summary: Cant deploy maven webapp on Wildfly 9.0.0 CR1
Product: serverplugins Reporter: satory
Component: WildFlyAssignee: ehsavoie <ehsavoie>
Status: RESOLVED DUPLICATE    
Severity: normal CC: phejl
Priority: P3    
Version: 8.0.2   
Hardware: PC   
OS: Linux   
Issue Type: DEFECT Exception Reporter:

Description satory 2015-06-01 16:50:12 UTC
I recently added Wildfly 9.0.0 CR1 to netbeans, but I am unable to deploy my project to it.

When I select Run, the run project output window opens and the following output is displayed:
NetBeans: Deploying on WildFly Application Server
    profile mode: false
    debug mode: false
    force redeploy: true
Starting WildFly Application Server


Then the application services output window opens and I can see the application server start properly.  Once that has finished the project window kicks off again with a maven build of the project, and once the successful build is complete, I get the following error:

------------------------------------------------------------------------
BUILD SUCCESS
------------------------------------------------------------------------
Total time: 3.630s
Finished at: Mon Jun 01 17:44:43 IST 2015
Final Memory: 16M/163M
------------------------------------------------------------------------
NetBeans: Deploying on WildFly Application Server
    profile mode: false
    debug mode: false
    force redeploy: true
Starting WildFly Application Server
WildFly Application Server Start Failed. HTTP Connector port 8080 is already in use.
Comment 1 Petr Hejl 2015-06-10 15:29:02 UTC
This is likely duplicate of issue #252742.
Comment 2 ehsavoie 2015-06-16 07:58:06 UTC
WildFly Application Server Start Failed. HTTP Connector port 8080 is already in use.
Looks like you already have something running on 8080.

Be careful if you are using netbeans 8.0.1 as the current wildfly plugin doesn't detect WildFLy 9 correctly. You have to use the nightly builds.
Comment 3 satory 2015-06-16 16:53:12 UTC
Reopening as I don't think thats correct..

Wildfly is start in the Server output window, like I mentioned in the initial comment.  Once thats started the maven build kicks off and after thats successful Netbeans tries to start Wildfly again, hence the port 8080 already in use.

Maybe netbeans shouldn't be attempting to start the server twice?
Comment 4 ehsavoie 2015-06-17 07:35:38 UTC
Like I said Wildfly 9.0.0 CR1 is not detected correctly thus Netbeans doesn't 'know' that the server has started and starts it again.

*** This bug has been marked as a duplicate of bug 252742 ***
Comment 5 ckinfos 2015-10-16 18:47:47 UTC
i can also say that even with the beta/rc netbeans 8.1 tha wildfly 9 or the wildfly 10 rc2 has still the same issue! 8080 port is in use...even if the port has changed for the wildfly the ide displays the message...for 8080. Not even the tree application server structure works and no running icon appears!