This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 259100

Summary: org.netbeans.spi.project.support.ant.PropertyUtils.resolveFile: LowPerformance took 21056 ms.
Product: projects Reporter: Exceptions Reporter <exceptions_reporter>
Component: AntAssignee: Tomas Stupka <tstupka>
Status: RESOLVED FIXED    
Severity: normal Keywords: PERFORMANCE
Priority: P3    
Version: 8.1   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter: 223835
Attachments: nps snapshot

Description Exceptions Reporter 2016-05-02 19:30:28 UTC
This bug was originally marked as duplicate of bug 230311, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 8.1 (Build 201510222201)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.73-b02, Java(TM) SE Runtime Environment, 1.8.0_73-b02
OS: Windows 10

User Comments:
GUEST: Fixing imports



Maximum slowness yet reported was 21056 ms, average is 21056
Comment 1 Exceptions Reporter 2016-05-02 19:30:29 UTC
Created attachment 159514 [details]
nps snapshot
Comment 2 Tomas Stupka 2016-07-05 16:12:06 UTC
fixed in jet-main #7e017a99e603
Comment 3 Quality Engineering 2016-07-07 01:52:01 UTC
Integrated into 'main-silver', will be available in build *201607070002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/7e017a99e603
User: Tomas Stupka <tstupka@netbeans.org>
Log: Issue #259100 - org.netbeans.spi.project.support.ant.PropertyUtils.resolveFile: LowPerformance took 21056 ms.