This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 26740

Summary: We should keep & manage ProjectObject in some of our classes
Product: ide Reporter: Jan Jancura <jjancura>
Component: CodeAssignee: Jan Jancura <jjancura>
Status: RESOLVED WONTFIX    
Severity: blocker    
Priority: P1    
Version: 3.x   
Hardware: All   
OS: All   
Issue Type: TASK Exception Reporter:
Bug Depends on: 23270, 26741, 27144    
Bug Blocks: 26422    

Description Jan Jancura 2002-08-23 16:47:39 UTC
Some TopComponents (Editor, Form Editor) should
keep Project Context
Comment 1 Jan Jancura 2002-08-27 18:04:27 UTC
DataObject will not provide project dependent cookies. So we should
keep ProjectObject in some of our classes and use
ProjectObject.getEnvironment ().lookup (Cookie.class)

Comment 2 Jan Jancura 2002-08-27 18:04:35 UTC
*** Issue 26762 has been marked as a duplicate of this issue. ***
Comment 3 Vitezslav Stejskal 2003-11-27 12:18:21 UTC
As described in
http://www.netbeans.org/servlets/ReadMsg?msgId=619519&listName=nbdiscuss the
current work on projects prototype has been stopped.