This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 269955

Summary: IllegalArgumentException: No parser for mime type: text/html
Product: editor Reporter: julienrondeau
Component: OptionsAssignee: Milutin Kristofic <mkristofic>
Status: NEW ---    
Severity: normal    
Priority: P3    
Version: 8.2   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter: 223912
Attachments: stacktrace

Description julienrondeau 2017-03-01 12:51:43 UTC
Build: NetBeans IDE 8.2 (Build 201609300101)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.101-b13, Java(TM) SE Runtime Environment, 1.8.0_101-b13
OS: Mac OS X

User Comments:

GUEST: please find error below


julienrondeau: I set up a new php project. and I was setting up the workflow with gulp. I get this error. I try to reinstall netbean8.2 but still get the error and cannot open a projet, or if it succeed, cannot open a file

GUEST: Ran into this just opening a maven project

GUEST: Can't open any html files anymore. When I clear all caches, the problem disappears for a few months, then comes back.

GUEST: Just repoened NB, none of my Java projects will show files in the project explorer.  All say Please Wait...

GUEST: Not sure what initiated this problem, but somehow the text/html editor has vanished. This happened before, deleting my settings folder fixed it then, but also meant I had to redo my settings. Reinstalling and upgrading from 8.0 to 8.1 (with settings import) did not help.

java.lang.IllegalArgumentException: No parser for mime type: text/html
   at org.netbeans.modules.parsing.nb.DataObjectEnvFactory.findMimeParser(
   at org.netbeans.modules.parsing.api.ParserManager.findParser(
   at org.netbeans.modules.parsing.api.ParserManager.parseWhenScanFinished(
   at org.netbeans.modules.web.clientproject.remotefiles.RemoteFiles.update(
   at org.netbeans.modules.web.clientproject.remotefiles.RemoteFiles.getRemoteFiles(
   at org.netbeans.modules.web.clientproject.remotefiles.RemoteFilesNodeFactoryImpl$RemoteFilesNodeListImpl.keys(
Comment 1 julienrondeau 2017-03-01 12:51:45 UTC
Created attachment 163735 [details]
Comment 2 julienrondeau 2017-03-01 12:54:14 UTC
impossible to work then... what can I do? help please!