This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 270025

Summary: Difficult to right click using trackpad on lists
Product: ide Reporter: gansan
Component: UIAssignee: issues@ide <issues>
Status: REOPENED ---    
Severity: normal    
Priority: P3    
Version: 8.2   
Hardware: Macintosh (x86)   
OS: Mac OS X   
Issue Type: DEFECT Exception Reporter:

Description gansan 2017-03-09 01:31:16 UTC
This issue was encountered using a late 2016 MacBook Pro 15" when using the trackpad. MacOS 10.12.3.

When using the trackpad, attempting to right click on items by using a two finger tap, on items such as entries in the projects window, the view scrolls upward or downward at the same time as the right click is registered, resulting in the wrong item being selected. This happens no matter how carefully I try to click without moving my fingers vertically. I do no encounter this issue in any other application and I don't believe it is my fingers' movement.

I am able to reduce the occurrence of this by reducing the scrolling speed in the control panel. However, even with scroll speed set fairly slow, it happens around 50% of the time.

Please see the attached video.
Comment 1 gansan 2017-03-09 01:48:59 UTC
I made a video illustrating the problem.
Comment 2 aikebah 2017-03-29 13:37:03 UTC
I also encountered this issue (on a Mac Pro late 2013; NetBeans IDE 8.2 (Build 201609300101); Java 1.8.0_121; Java HotSpot(TM) 64-Bit Server VM 25.121-b13) would love to see it be solved so that I don't have to grab and connect a mouse when I want to edit some code.
Comment 3 d2g 2017-05-22 11:33:52 UTC
Myself and coworkers using Netbeans 8.2 in Macbook pro are having this issue. It's very frustrating to have the double cliks and to involuntary scroll the screen, resulting in no db click menu shown or wrong selection on dbclick menu. Please fix it!
Comment 4 geometrikal 2017-07-18 06:20:26 UTC
Same here... any fix yet?
Comment 5 geometrikal 2017-07-18 06:20:58 UTC
Btw - does not occur for me on 8.1
Comment 6 stefan_w 2017-07-25 14:28:55 UTC
This looks to be an issue with Java 8 on Mac OS

I was running into same problem some month back when upgrading from JDK 1.8.0_111 to JDK 1.8.0_121

Today tried running Netbeans 8.2 with JDK 1.8.0_141 and the phenomenon started again.
I'm now downgrading the Java version using the netbeans_jdkhome parameter.
Comment 7 jcstritt 2017-08-15 19:50:56 UTC
It seems that it now works with the JDK 8u144. I also completely deleted the / Users / username / Library / Application Support / NetBeans / 8.2 / config / Windows2Local folder before restarting NetBeans.
Comment 8 jcstritt 2017-08-15 20:21:00 UTC
Finally don't work with JDKu144