This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 36681

Summary: ISE when finishing IMT
Product: java Reporter: Milan Kubec <mkubec>
Component: UnsupportedAssignee: issues@java <issues>
Status: VERIFIED FIXED    
Severity: blocker CC: jglick
Priority: P1 Keywords: THREAD
Version: 3.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on: 35833    
Bug Blocks:    
Attachments: exc stack trace

Description Milan Kubec 2003-10-20 09:22:59 UTC
IllegalStateException is thrown when clicking
'Finish' on IMT. After that IDE deadlocks see #36672.
Comment 1 Milan Kubec 2003-10-20 09:23:24 UTC
Created attachment 11908 [details]
exc stack trace
Comment 2 Jesse Glick 2003-10-20 15:44:38 UTC
This will be fixed automatically as part of issue #35833, so you may
not want to bother fixing it before then (I don't know).
Comment 3 Jesse Glick 2003-10-20 15:45:44 UTC
Problem is in srcmodel, BTW - ElementNode firing a cookie change
outside EQ, which tries to update actions. In #35833,
Node.fireCookieChange would automatically push the event into EQ.
Comment 4 Jesse Glick 2003-10-20 15:47:27 UTC
*** Issue 36672 has been marked as a duplicate of this issue. ***
Comment 5 _ gtzabari 2003-10-20 15:53:46 UTC
Increasing to P1 (as was the case in the duplicate issue that was closed).
Comment 6 Jesse Glick 2003-10-20 17:35:41 UTC
Simplest fix would be for ElementNode.ElementListener.propertyChange
to wrap its entire body in

Mutex.EVENT.writeAccess(new Runnable() {
    public void run() {
        // as before...
    }
});
Comment 7 Jesse Glick 2003-10-22 18:07:47 UTC
*** Issue 36605 has been marked as a duplicate of this issue. ***
Comment 8 Jesse Glick 2003-10-22 18:09:48 UTC
Hello, is anyone paying attention? Add four lines of source code, run
a clean build & validation suite, check in... not so hard.
Comment 9 Tomas Hurka 2003-10-24 09:26:07 UTC
Ok, I will fix it next week.
Comment 10 Milan Kubec 2003-10-24 09:39:01 UTC
Please, do it before Q-build, otherwise there will be no Q-build next
week. Thanks
Comment 11 Tomas Hurka 2003-10-27 08:05:58 UTC
Fixed in trunk
/cvs/java/srcmodel/src/org/openide/src/nodes/ElementNode.java,v  <--  
ElementNode.java
new revision: 1.5; previous revision: 1.4
done
Comment 12 Milan Kubec 2003-11-14 09:54:22 UTC
Verified.
Comment 13 Quality Engineering 2007-09-20 12:26:32 UTC
Reorganization of java component