This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 41154

Summary: Deleting files takes longer after the new build system was integrated in trunk
Product: projects Reporter: Antonin Nebuzelsky <anebuzelsky>
Component: Generic InfrastructureAssignee: Tomas Zezula <tzezula>
Status: CLOSED DUPLICATE    
Severity: blocker CC: dkonecny, issues
Priority: P2 Keywords: PERFORMANCE, REGRESSION
Version: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 41535    

Description Antonin Nebuzelsky 2004-03-19 15:39:09 UTC
There is a significant performance regression in
trunk in deleting files from within the IDE after
the new BuildSys was integrated.

Here are results from testing on W2K (Dell
Precision 220, PIII 800MHz, 512MB RAM, Windows
2000) and Linux (Dell Latitude C840, PIV 2.2GHz,
1024MB RAM, Red Hat 9). Each test was repeated
three times.

1) Delete a folder w/ 1000 simple java files

W2K:
200403141900 -  9516ms,  8062ms,  8922ms
200403191248 - 16125ms, 16188ms, 17875ms

Linux:
200403141900 - 3697ms, 3479ms, 3199ms
200403191248 - 4305ms, 4647ms, 4352ms

2) Delete a folder w/ 1000 simple text files

W2K:
200403141900 -  6906ms,  6703ms,  6797ms
200403191248 - 12375ms, 12219ms, 12203ms

Linux:
200403141900 - 2473ms, 3349ms, 2440ms
200403191248 - 4198ms, 3411ms, 3337ms
Comment 1 Antonin Nebuzelsky 2004-05-27 13:09:58 UTC
Tomasi, I've done measurements with today's trunk and deleting folder
with 1000 javas is even worse than before. And on W2K it takes
ridiculously long. The numbers below are measured with my build
200405271200.

1) Delete a folder w/ 1000 simple java files

W2K: 188s, 187s
Linux: 15747ms, 17484ms, 18180ms

2) Delete a folder w/ 1000 simple text files

W2K: 187s, 186s
Linux: 14688ms, 15397ms, 17057ms

I will look into the W2K case in profiler.
Comment 2 Antonin Nebuzelsky 2004-05-28 18:20:22 UTC
Tomasi, I've found what is the problem with the very long times on
Windows. You can see details in issue 44003.
Comment 3 Antonin Nebuzelsky 2004-06-08 14:19:05 UTC
Closing as duplicate of issue 43278 because as refactoring is in trunk
now we don't need to have two bugs covering one functionality. Tomasi,
add your comments to 43278. Thanks.

*** This issue has been marked as a duplicate of 43278 ***
Comment 4 Marian Mirilovic 2005-07-15 07:53:25 UTC
closed