This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 42992

Summary: masterfs: ResourcePath leak
Product: platform Reporter: _ pkuzel <pkuzel>
Component: FilesystemsAssignee: rmatous <rmatous>
Status: RESOLVED FIXED    
Severity: blocker CC: issues, mpetras
Priority: P2 Keywords: PERFORMANCE
Version: 3.x   
Hardware: PC   
OS: Linux   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 19484, 41448    
Attachments: Path to GC root.

Description _ pkuzel 2004-05-10 13:31:39 UTC
I searched a11y folder for NOTHING. Nothing was
found and visualized. Still 251 ResourcePaths,
WeakHashMaps and ReferenceQueues appeared and
remaining.

ResourcePath.getChild()
Comment 1 _ pkuzel 2004-05-10 13:32:38 UTC
Created attachment 14782 [details]
Path to GC root.
Comment 2 _ pkuzel 2004-05-10 13:34:00 UTC
I suspect the chldsCache.
Comment 3 _ pkuzel 2004-05-10 18:00:55 UTC
Commenting out chldsCache.put() in ResourcePath.getChild() eliminates
major part of issue #19484 leak.
Comment 4 _ pkuzel 2004-05-11 14:31:29 UTC
*** Issue 41445 has been marked as a duplicate of this issue. ***
Comment 5 _ pkuzel 2004-05-11 14:32:26 UTC
Inheriting blocks from duplicated issue.
Comment 6 rmatous 2004-05-11 14:47:57 UTC
/cvs/openide/masterfs/src/org/netbeans/modules/masterfs/ResourcePath.java
new revision: 1.6; previous revision: 1.5