This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 43224

Summary: NPE when the moved project was opened
Product: projects Reporter: pzajac <pzajac>
Component: AntAssignee: Jesse Glick <jglick>
Status: CLOSED WORKSFORME    
Severity: blocker    
Priority: P2    
Version: 4.x   
Hardware: PC   
OS: Linux   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 41535    
Attachments: exception stacktrace

Description pzajac 2004-05-13 16:26:30 UTC
[2004051111800]
Steps to reproduction:
1) create a folder X
2) create a j2se project A in the folder X
3) create a j2se project B in the folder X
4) add the project A  to the project B classpath
5) close the projects
6) close ide
7) rename folder X to Y
8) open project Y/A 

the NPE was thrown.
Comment 1 pzajac 2004-05-13 16:26:59 UTC
Created attachment 14850 [details]
exception stacktrace
Comment 2 Jesse Glick 2004-05-13 19:35:40 UTC
Sorry, can't reproduce.

I can put in some additional error checks into some classes to help
diagnose it in the future, but I can't even guess what would cause this.

Note - if you open y/b, you will need to adjust the path to a from x/a
to y/a in y/b/nbproject/private/private.properties. This is only true
if you were not using version control and so .../x/a was stored as an
absolute path; if the projects were inside some VCS working dir this
should not be necessary because "../a" is stored as the path to a from b.
Comment 3 pzajac 2004-06-02 13:16:07 UTC
v