This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 43609

Summary: FileBuiltQuery.getStatus(fObj) returns null for file object is from project with existing sources
Product: projects Reporter: Jiri Skrivanek <jskrivanek>
Component: AntAssignee: Jesse Glick <jglick>
Status: CLOSED FIXED    
Severity: blocker    
Priority: P3    
Version: 4.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Bug Depends on:    
Bug Blocks: 41535    

Description Jiri Skrivanek 2004-05-20 11:56:27 UTC
If you create a java project with existing
sources, icons of java files are not properly
badged. That means compilation or error symbol
doesn't appear  next to the icon anytime. It is
caused by the fact that
FileBuiltQuery.getStatus(fObj) returns null if
file object is from project with existing sources.

Tested in build 20040520-0809, JDK1.4.2_04, WindowsXP.
Comment 1 Jesse Glick 2004-05-20 14:55:35 UTC
Yes, I know; GlobFileBuiltQuery is simply not implemented for external
source roots.
Comment 2 Jesse Glick 2004-08-10 00:02:54 UTC
Working patch & test.
Comment 3 Jesse Glick 2004-08-10 02:57:57 UTC
Fixed including patches for issue #45018 and issue #45694:

committed   * Up-To-Date  1.21       
ant/project/src/org/netbeans/spi/project/support/ant/AntProjectHelper.java
committed   * Up-To-Date  1.10       
ant/project/src/org/netbeans/spi/project/support/ant/GlobFileBuiltQuery.java
committed   * Up-To-Date  1.10       
ant/project/test/unit/src/org/netbeans/spi/project/support/ant/GlobFileBuiltQueryTest.java
Comment 4 Jiri Skrivanek 2004-08-27 12:58:02 UTC
Verified in build 20040826-0215.